summaryrefslogtreecommitdiff
path: root/dev-dotnet/csharp-gentoodotnetinfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-16 04:59:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-16 04:59:22 +0100
commitc748acf4192a1e08c9feb2d5f0004937a4869639 (patch)
tree3d3802bdd2770dc25d23a317afd0149df5a53cb2 /dev-dotnet/csharp-gentoodotnetinfo
parentd458376753e8fa261bdf469a99543577fb8d95a0 (diff)
gentoo auto-resync : 16:09:2023 - 04:59:22
Diffstat (limited to 'dev-dotnet/csharp-gentoodotnetinfo')
-rw-r--r--dev-dotnet/csharp-gentoodotnetinfo/Manifest3
-rw-r--r--dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-0.1.0.ebuild44
-rw-r--r--dev-dotnet/csharp-gentoodotnetinfo/metadata.xml13
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-dotnet/csharp-gentoodotnetinfo/Manifest b/dev-dotnet/csharp-gentoodotnetinfo/Manifest
new file mode 100644
index 000000000000..0a4700417221
--- /dev/null
+++ b/dev-dotnet/csharp-gentoodotnetinfo/Manifest
@@ -0,0 +1,3 @@
+DIST csharp-gentoodotnetinfo-0.1.0.tar.bz2 8207 BLAKE2B d6c9bbd83b15487c669bb933c51a266788e7217a59fccb6e6fb87b66cd77ea67325859fb030d45a9ae00a542c23158a88d90ab915956d2086a4c2a3954d6a75f SHA512 78cbb0768eb8434c5ccf7c3ddbee8fc3c742e3875a05d99a72fbaa798fdd92a0bd231be873be01385b1933f51c14af9a2827e6da9495fc943898984684ab077c
+EBUILD csharp-gentoodotnetinfo-0.1.0.ebuild 897 BLAKE2B b24c4c5a27eb19ca7e228ba3af06bad3ff0e262c78c4ef17e86cf2cda24a3f85802e64097866bc5ddd77eae87d6007c956ada19094c8f3fdcda4ab460c86fc14 SHA512 c3bced0795f46b9aac2a86783e2932caf377518273e77a9e2e71073550361837fabf107bc362a08ce133cacb88dae39fd489fe5ae5a5761f5bbb999892a20530
+MISC metadata.xml 441 BLAKE2B 19f6f9bf53a7f2cbadd053dafa583aefa466e23b17cd2dc2c6f31af5b2432a3191341730569cedff2358d47c612f27476d67b8fe1c3b6df32022d41543ef1661 SHA512 8979243a5a0db2fdc61bb0fa3c0e3a7771d2ed7da49ef8e6cd6ba4d770e855a1d3604b275568e97719e1cedaa817a85d3a8778daf37f0d980e6d3d64ef218f93
diff --git a/dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-0.1.0.ebuild b/dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-0.1.0.ebuild
new file mode 100644
index 000000000000..dfe457e4f24f
--- /dev/null
+++ b/dev-dotnet/csharp-gentoodotnetinfo/csharp-gentoodotnetinfo-0.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOTNET_PKG_COMPAT=7.0
+unset NUGET_PACKAGES
+
+inherit dotnet-pkg
+
+DESCRIPTION=".NET information tool for Gentoo"
+HOMEPAGE="https://gitlab.gentoo.org/dotnet/csharp-gentoodotnetinfo/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.gentoo.org/dotnet/${PN}.git"
+else
+ SRC_URI="https://gitlab.gentoo.org/dotnet/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOTNET_PKG_PROJECTS=(
+ "${S}/Source/gentoodotnetinfo/GentooDotnetInfo/GentooDotnetInfo.csproj"
+)
+
+src_unpack() {
+ dotnet-pkg_src_unpack
+
+ if [[ -n ${EGIT_REPO_URI} ]] ; then
+ git-r3_src_unpack
+ fi
+}
+
+src_install() {
+ dotnet-pkg-base_install
+ dotnet-pkg-base_dolauncher_portable \
+ "/usr/share/${P}/GentooDotnetInfo.dll" gentoo-dotnet-info
+
+ einstalldocs
+}
diff --git a/dev-dotnet/csharp-gentoodotnetinfo/metadata.xml b/dev-dotnet/csharp-gentoodotnetinfo/metadata.xml
new file mode 100644
index 000000000000..8f2f8b5c9dde
--- /dev/null
+++ b/dev-dotnet/csharp-gentoodotnetinfo/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.com/xgqt/csharp-gentoodotnetinfo/-/issues/</bugs-to>
+ <remote-id type="gitlab">xgqt/csharp-gentoodotnetinfo</remote-id>
+ </upstream>
+</pkgmetadata>