summaryrefslogtreecommitdiff
path: root/dev-dotnet/notify-sharp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-dotnet/notify-sharp/files
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-dotnet/notify-sharp/files')
-rw-r--r--dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20080912-control-docs.patch28
-rw-r--r--dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20090305-dbus-sharp.patch60
2 files changed, 0 insertions, 88 deletions
diff --git a/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20080912-control-docs.patch b/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20080912-control-docs.patch
deleted file mode 100644
index 44ff05881fb4..000000000000
--- a/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20080912-control-docs.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -NrU5 notify-sharp-20080912.orig/configure.ac notify-sharp-20080912/configure.ac
---- notify-sharp-20080912.orig/configure.ac 2008-11-26 21:56:02.000000000 +0100
-+++ notify-sharp-20080912/configure.ac 2008-11-26 22:01:08.000000000 +0100
-@@ -34,16 +34,21 @@
- if test "x$GACUTIL" = "xno"; then
- AC_MSG_ERROR([You need to install gacutil])
- fi
- AC_SUBST(GACUTIL)
-
--AC_ARG_ENABLE(docs, AC_HELP_STRING([--disable-docs],
-- [Do not build documentation]), with_docs=no, with_docs=yes)
-+AC_ARG_ENABLE( [docs],
-+ [AC_HELP_STRING( [--enable/disable-docs],
-+ [Do (not) build documentation (default=yes)]
-+ )],
-+ [],
-+ [enable_docs=yes]
-+)
-
- MONODOC_REQ_VERSION=1.1.18
-
--if test "x$with_docs" = "xyes"; then
-+if test "x$enable_docs" = "xyes"; then
- PKG_CHECK_MODULES(MONODOC, monodoc >= $MONODOC_REQ_VERSION,,
- [AC_MSG_ERROR([You need to install monodoc, or pass --disable-docs to configure to skip documentation installation])])
- AC_PATH_PROG(MONODOCER, monodocer, no)
- if test "x$MONODOCER" = "xno"; then
- AC_MSG_ERROR([You need to install monodoc, or pass --disable-docs to configure to skip documentation installation])
diff --git a/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20090305-dbus-sharp.patch b/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20090305-dbus-sharp.patch
deleted file mode 100644
index 28c6316dc5aa..000000000000
--- a/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20090305-dbus-sharp.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index d2ff635..7200f06 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -71,11 +71,11 @@ GTK_SHARP_REQ_VERSION=2.10.1
- PKG_CHECK_MODULES(GTK_SHARP, gtk-sharp-2.0 >= $GTK_SHARP_REQ_VERSION)
- AC_SUBST(GTK_SHARP_LIBS)
-
--NDESK_DBUS_REQ_VERSION=0.4
--NDESK_DBUS_GLIB_REQ_VERSION=0.3
--PKG_CHECK_MODULES(NDESK_DBUS, ndesk-dbus-1.0 >= $NDESK_DBUS_REQ_VERSION \
-- ndesk-dbus-glib-1.0 >= $NDESK_DBUS_GLIB_REQ_VERSION)
--AC_SUBST(NDESK_DBUS_LIBS)
-+DBUS_SHARP_REQ_VERSION=0.7
-+DBUS_SHARP_GLIB_REQ_VERSION=0.5
-+PKG_CHECK_MODULES(DBUS_SHARP, dbus-sharp-1.0 >= $DBUS_SHARP_REQ_VERSION \
-+ dbus-sharp-glib-1.0 >= $DBUS_SHARP_GLIB_REQ_VERSION)
-+AC_SUBST(DBUS_SHARP_LIBS)
-
- required_assemblies="Mono.Posix"
-
-diff --git a/src/Global.cs b/src/Global.cs
-index eedefbf..a0f80ed 100644
---- a/src/Global.cs
-+++ b/src/Global.cs
-@@ -24,7 +24,7 @@ using System;
- using System.Reflection;
- using System.Collections.Generic;
-
--using NDesk.DBus;
-+using DBus;
- using org.freedesktop;
- using org.freedesktop.DBus;
-
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 3b39c23..50bbb39 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -7,7 +7,7 @@ CSFLAGS = \
- LIBFLAGS = \
- -r:Mono.Posix \
- $(GTK_SHARP_LIBS) \
-- $(NDESK_DBUS_LIBS)
-+ $(DBUS_SHARP_LIBS)
-
- CSFILES = \
- $(srcdir)/Global.cs \
-diff --git a/src/Notification.cs b/src/Notification.cs
-index 09ef83e..e2ab72f 100644
---- a/src/Notification.cs
-+++ b/src/Notification.cs
-@@ -28,7 +28,7 @@ using GLib;
- using Gdk;
- using Gtk;
-
--using NDesk.DBus;
-+using DBus;
- using org.freedesktop;
- using org.freedesktop.DBus;
-