summaryrefslogtreecommitdiff
path: root/dev-embedded/arduino-ctags
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-embedded/arduino-ctags
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-embedded/arduino-ctags')
-rw-r--r--dev-embedded/arduino-ctags/Manifest3
-rw-r--r--dev-embedded/arduino-ctags/arduino-ctags-20161123.ebuild30
-rw-r--r--dev-embedded/arduino-ctags/metadata.xml17
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-embedded/arduino-ctags/Manifest b/dev-embedded/arduino-ctags/Manifest
new file mode 100644
index 000000000000..7d78925654ef
--- /dev/null
+++ b/dev-embedded/arduino-ctags/Manifest
@@ -0,0 +1,3 @@
+DIST arduino-ctags-20161123.tar.gz 490200 BLAKE2B f51b18a0db420124c5fed2b320c16d9eeb96fce6d0f118cf43a8177f88400daaeb83437c3993353c16b73781961c7476e782e66891582f4b3dc5301c73da64dc SHA512 ae5bde92c3dd0b9a179bc1df998f20312c4ab8b2c9c1840dbe543d23fb4531b9e5524f1399d9922ed9b2de4582bdb74635f7ec576a42c808d152c3fbb84f9687
+EBUILD arduino-ctags-20161123.ebuild 738 BLAKE2B d1819283886e1c211496388632a5573c0f55db9d89b047314acdb4a77eee379e5a488a3a374598dd57a53f246a4753d2cb3bebadcdc619e0105cb078cd324aeb SHA512 5b1e043f0ce8b3472be0f05b1e2601c7822db932d1e5c02fecf5f4cb4b4b3adb3b0d7e3cbb99c8d06123df4c1cabc7538ab5844fcb3102e7573991f2186380a9
+MISC metadata.xml 626 BLAKE2B 723945b93e97337df1fc85a27c7fb937d624372a1732ef026d0541ab6179806aaa8416e3e973873d7b2b2d5c39a32391158a1d0e172b02aa35b9c20aa1619ee7 SHA512 e129f6dec30edb56b3a85f26c171d314445c8bbe44cfb7e5fdd7f4d18a763fa13a79a6af95b7d0195bbc33b51d67fe84e33f402d30bf5672a7e7262738fba72f
diff --git a/dev-embedded/arduino-ctags/arduino-ctags-20161123.ebuild b/dev-embedded/arduino-ctags/arduino-ctags-20161123.ebuild
new file mode 100644
index 000000000000..e2bcd0810ab1
--- /dev/null
+++ b/dev-embedded/arduino-ctags/arduino-ctags-20161123.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMITHASH="abc8fca7499f44c725122881cd380a88c37abe0e"
+
+DESCRIPTION="Arduino private fork of dev-util/ctags"
+HOMEPAGE="https://github.com/arduino/ctags"
+SRC_URI="https://github.com/arduino/ctags/archive/${COMMITHASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/ctags-${COMMITHASH}"
+
+src_configure() {
+ econf \
+ --disable-readlib \
+ --disable-etags \
+ --enable-tmpdir="${EPREFIX}"/tmp
+}
+
+src_install() {
+ # This package compiles into a "ctags" executable, but don't want to clash into
+ # actually legitimate ctags implementations.
+ mv ctags arduino-ctags
+ dobin arduino-ctags
+}
diff --git a/dev-embedded/arduino-ctags/metadata.xml b/dev-embedded/arduino-ctags/metadata.xml
new file mode 100644
index 000000000000..6e4776276159
--- /dev/null
+++ b/dev-embedded/arduino-ctags/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>embedded@gentoo.org</email>
+ <name>Embedded Gentoo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">arduino/ctags</remote-id>
+ </upstream>
+ <longdescription>
+ Arduino's build process includes a preprocessing phase that involves ctags,
+ but not any version of ctags, *Arduino's* ctags, a private fork that
+ Arduino maintains. We can't use dev-util/ctags because it causes Arduino
+ to produce corrupt executables.
+ </longdescription>
+</pkgmetadata>