summaryrefslogtreecommitdiff
path: root/dev-embedded/parapin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-embedded/parapin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-embedded/parapin')
-rw-r--r--dev-embedded/parapin/Manifest3
-rw-r--r--dev-embedded/parapin/metadata.xml18
-rw-r--r--dev-embedded/parapin/parapin-1.0.0.ebuild41
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-embedded/parapin/Manifest b/dev-embedded/parapin/Manifest
new file mode 100644
index 000000000000..0e47ae6972c3
--- /dev/null
+++ b/dev-embedded/parapin/Manifest
@@ -0,0 +1,3 @@
+DIST parapin-1.0.0.tar.gz 240771 BLAKE2B 3c211d43028f1ee4b09568eae2408b96c9b3c1ecce5b81f3fd520ea3f480bb06044e99e04e7776b8a2b6cf7f99e57f2dcf186aea2ba9afbe4c31b9e0be3bc894 SHA512 43e4066b649bec8519c98052451ab1beb720c9c8086bbd045bb013e3c12c7e83bf0411ac4b8e7006c3acbc6d1487b918d26df65b246469e6c7e008a0e26874d9
+EBUILD parapin-1.0.0.ebuild 775 BLAKE2B 4cf48813609462289869def43d3a4e9d3e347d401299281e10ca89db1cb6c811e294ba38041c5354b2901969aa451bdf7d4a4fd964d94955d94aa3363cdec294 SHA512 e3df0592adf1bb8d7a00c5c07a7ecfaa45df9384c7f8f29260e69a425421f1d10ce9de8d3360542ddc3516c9b13be4564857e7505cfb8010906e4a046dc51640
+MISC metadata.xml 987 BLAKE2B bc9d93c4a6baa98b6ee8631a33a9ccc4fec6bcd9a60adff8cca4f2376cf12145571bc23ad1dab299eda69cfffa77f0ea5a1e3cb72a26b6c25f9d7253b4048af4 SHA512 80c14ff7464a986fb91620df2c239c04be1098b38046d0516b9e38e85eeda520c06437ddaccbcca322f99fec8161645f15c83c042165a9a83a24cc14aee60db0
diff --git a/dev-embedded/parapin/metadata.xml b/dev-embedded/parapin/metadata.xml
new file mode 100644
index 000000000000..434e29779329
--- /dev/null
+++ b/dev-embedded/parapin/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>embedded@gentoo.org</email>
+ <name>Embedded Gentoo</name>
+ </maintainer>
+ <longdescription>
+Parapin makes it easy to write C code under Linux that controls individual pins on a PC parallel port. This kind of control is very useful for
+electronics projects that use the PC's parallel port as a generic digital I/O interface. Parapin goes to great lengths to insulate the programmer
+from the somewhat complex parallel port programming interface provided by the PC hardware, making it easy to use the parallel port for digital
+I/O. By the same token, this abstraction also makes Parapin less useful in applications that need to actually use the parallel port as a parallel
+port (e.g., for talking to a printer).
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">parapin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-embedded/parapin/parapin-1.0.0.ebuild b/dev-embedded/parapin/parapin-1.0.0.ebuild
new file mode 100644
index 000000000000..d2bc30ea19ae
--- /dev/null
+++ b/dev-embedded/parapin/parapin-1.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit toolchain-funcs
+
+DESCRIPTION="A parallel port pin programming library"
+HOMEPAGE="http://parapin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+IUSE="doc"
+KEYWORDS="x86 ~amd64"
+
+SLOT="0"
+
+DEPEND="doc? ( dev-tex/latex2html )"
+RDEPEND=""
+
+src_compile() {
+ # Note 2.4 and 2.6 makefiles are identical for the targets used
+ emake -f Makefile-2.4 CC=$(tc-getCC) || die
+}
+
+src_install() {
+ dolib.a libparapin.a
+ insopts -m0444; insinto /usr/include; doins parapin.h
+
+ dodoc README
+ if use doc; then
+ cd doc
+ emake html
+ cd parapin
+ dohtml *.html *.css *.png
+
+ cd ${S}
+ docinto examples
+ dodoc examples/*.c
+ fi
+}