summaryrefslogtreecommitdiff
path: root/dev-embedded/pk2-la/pk2-la-1.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-embedded/pk2-la/pk2-la-1.1-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-embedded/pk2-la/pk2-la-1.1-r2.ebuild')
-rw-r--r--dev-embedded/pk2-la/pk2-la-1.1-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-embedded/pk2-la/pk2-la-1.1-r2.ebuild b/dev-embedded/pk2-la/pk2-la-1.1-r2.ebuild
new file mode 100644
index 000000000000..342d462055c4
--- /dev/null
+++ b/dev-embedded/pk2-la/pk2-la-1.1-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Logic Analyzer and I/O Probe for the Microchip PICkit2"
+HOMEPAGE="https://sourceforge.net/projects/pk2-la"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/pyusb:0[${PYTHON_USEDEP}]
+ "
+
+src_compile() { :; }
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+
+ dodoc README LA-Format IO-Format CHANGELOG
+}