summaryrefslogtreecommitdiff
path: root/dev-embedded/powersoftplus-libftdi/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-embedded/powersoftplus-libftdi/files
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-embedded/powersoftplus-libftdi/files')
-rw-r--r--dev-embedded/powersoftplus-libftdi/files/powersoftplus-libftdi-0.1.8-LDFLAGS.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-embedded/powersoftplus-libftdi/files/powersoftplus-libftdi-0.1.8-LDFLAGS.patch b/dev-embedded/powersoftplus-libftdi/files/powersoftplus-libftdi-0.1.8-LDFLAGS.patch
new file mode 100644
index 000000000000..642209ea0ea1
--- /dev/null
+++ b/dev-embedded/powersoftplus-libftdi/files/powersoftplus-libftdi-0.1.8-LDFLAGS.patch
@@ -0,0 +1,23 @@
+diff --git a/libftdi/lib_table/Makefile b/libftdi/lib_table/Makefile
+index cf4316b..dd393b8 100644
+--- a/libftdi/lib_table/Makefile
++++ b/libftdi/lib_table/Makefile
+@@ -1,15 +1,15 @@
+ # which compiler
+-CC = gcc
++CC ?= gcc
+
+ VERSION = _RELEASE
+
+ LIBNAME = libd2xx_table.so
+
+-CFLAGS = -DLINUX -D$(VERSION)
++CFLAGS += -DLINUX -D$(VERSION)
+
+ $(LIBNAME): ftdi_table.o
+
+- $(CC) -Wall -shared -fPIC -o $(LIBNAME) ftdi_table.o
++ $(CC) -Wall -shared -fPIC ${LDFLAGS} -o $(LIBNAME) ftdi_table.o
+
+ ftdi_table.o: ftdi_table.c
+ $(CC) -I. $(CFLAGS) -c -fPIC ftdi_table.c