summaryrefslogtreecommitdiff
path: root/dev-embedded/xa/xa-2.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-22 17:18:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-22 17:18:34 +0000
commitfd87b7c771378b2116981e3924bee5805148e118 (patch)
tree91ed28393c7b534787d3c073e269fe598d0fd535 /dev-embedded/xa/xa-2.4.0.ebuild
parent77b74be093bdf4a0ed4121acc3f8e229103cf004 (diff)
gentoo auto-resync : 22:11:2023 - 17:18:34
Diffstat (limited to 'dev-embedded/xa/xa-2.4.0.ebuild')
-rw-r--r--dev-embedded/xa/xa-2.4.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-embedded/xa/xa-2.4.0.ebuild b/dev-embedded/xa/xa-2.4.0.ebuild
new file mode 100644
index 000000000000..7ad46858840c
--- /dev/null
+++ b/dev-embedded/xa/xa-2.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="High-speed, two-pass portable 6502 cross-assembler"
+HOMEPAGE="https://www.floodgap.com/retrotech/xa/"
+SRC_URI="https://www.floodgap.com/retrotech/xa/dists/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.0-make.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ emake DESTDIR="${ED}"/usr install
+ einstalldocs
+}