summaryrefslogtreecommitdiff
path: root/dev-erlang/jose/jose-1.11.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-erlang/jose/jose-1.11.2.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-erlang/jose/jose-1.11.2.ebuild')
-rw-r--r--dev-erlang/jose/jose-1.11.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-erlang/jose/jose-1.11.2.ebuild b/dev-erlang/jose/jose-1.11.2.ebuild
new file mode 100644
index 000000000000..728d04182c54
--- /dev/null
+++ b/dev-erlang/jose/jose-1.11.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit rebar
+
+DESCRIPTION="JSON Object Signing and Encryption (JOSE) for Erlang and Elixir"
+HOMEPAGE="https://github.com/potatosalad/erlang-jose"
+SRC_URI="https://github.com/potatosalad/erlang-jose/archive/${PV}.tar.gz
+ -> erlang-${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/erlang-19.0"
+RDEPEND="${DEPEND}"
+
+DOCS=( ALGORITHMS.md CHANGELOG.md README.md examples/KEY-GENERATION.md )
+
+# TODO: jose has test suite, but it require lots of dependencies. It may not be
+# TODO: urgent, but it would be nice to have those sooner or later.
+RESTRICT=test
+
+S="${WORKDIR}/erlang-${P}"