summaryrefslogtreecommitdiff
path: root/dev-erlang/riakc/riakc-2.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-erlang/riakc/riakc-2.4.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-erlang/riakc/riakc-2.4.2.ebuild')
-rw-r--r--dev-erlang/riakc/riakc-2.4.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-erlang/riakc/riakc-2.4.2.ebuild b/dev-erlang/riakc/riakc-2.4.2.ebuild
new file mode 100644
index 000000000000..511f7c788d79
--- /dev/null
+++ b/dev-erlang/riakc/riakc-2.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+MY_PN="riak-erlang-client"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Erlang clients for Riak"
+HOMEPAGE="https://github.com/basho/riak-erlang-client"
+SRC_URI="https://github.com/basho/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
+
+DEPEND=">=dev-erlang/riak_pb-2.1.4.2
+ >=dev-lang/erlang-17.1"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md RELNOTES.md )
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ rebar_src_prepare
+ # 'priv' directory contains only edoc.css, but doc isn't going to be built.
+ rm -r "${S}/priv" || die
+}