summaryrefslogtreecommitdiff
path: root/dev-erlang/sqlite3/sqlite3-1.1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-erlang/sqlite3/sqlite3-1.1.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-erlang/sqlite3/sqlite3-1.1.5.ebuild')
-rw-r--r--dev-erlang/sqlite3/sqlite3-1.1.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-erlang/sqlite3/sqlite3-1.1.5.ebuild b/dev-erlang/sqlite3/sqlite3-1.1.5.ebuild
new file mode 100644
index 000000000000..aa0125b074ce
--- /dev/null
+++ b/dev-erlang/sqlite3/sqlite3-1.1.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+MY_PN="erlang-sqlite3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="SQLite gen_server port for Erlang"
+HOMEPAGE="https://github.com/processone/erlang-sqlite3"
+SRC_URI="https://github.com/processone/${MY_PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="ErlPL-1.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
+
+DEPEND=">=dev-lang/erlang-17.1
+ dev-db/sqlite:3"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS README.md )
+
+S="${WORKDIR}/${MY_P}"