summaryrefslogtreecommitdiff
path: root/dev-games/KXL/KXL-1.1.7-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-games/KXL/KXL-1.1.7-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-games/KXL/KXL-1.1.7-r2.ebuild')
-rw-r--r--dev-games/KXL/KXL-1.1.7-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-games/KXL/KXL-1.1.7-r2.ebuild b/dev-games/KXL/KXL-1.1.7-r2.ebuild
new file mode 100644
index 000000000000..fc453d84b946
--- /dev/null
+++ b/dev-games/KXL/KXL-1.1.7-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="Development Library for making games for X"
+HOMEPAGE="http://kxl.orz.hm/"
+SRC_URI="http://kxl.hn.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+DEPEND="x11-libs/libX11"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-m4.patch \
+ "${FILESDIR}"/${P}-amd64.patch \
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}