summaryrefslogtreecommitdiff
path: root/dev-games/KXL/KXL-1.1.7_p17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-26 15:08:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-26 15:08:09 +0100
commit2ad011cd42b40aebf90105be4521fb1727266d1d (patch)
treed9dc4f7c1665a6ba336ba8a9fa773f1292895b76 /dev-games/KXL/KXL-1.1.7_p17.ebuild
parente0dcb1c4ea48292b379fadd53f55f1df42cf7eab (diff)
gentoo auto-resync : 26:09:2022 - 15:08:08
Diffstat (limited to 'dev-games/KXL/KXL-1.1.7_p17.ebuild')
-rw-r--r--dev-games/KXL/KXL-1.1.7_p17.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-games/KXL/KXL-1.1.7_p17.ebuild b/dev-games/KXL/KXL-1.1.7_p17.ebuild
new file mode 100644
index 000000000000..33e072b293c6
--- /dev/null
+++ b/dev-games/KXL/KXL-1.1.7_p17.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PV=$(ver_cut 1-3)
+DESCRIPTION="Development Library for making games for X"
+HOMEPAGE="http://kxl.orz.hm/"
+# http://kxl.hn.org/download/${P}.tar.gz
+SRC_URI="mirror://debian/pool/main/k/kxl/kxl_${MY_PV}.orig.tar.gz -> ${PN}-${MY_PV}.tar.gz"
+SRC_URI+=" mirror://debian/pool/main/k/kxl/kxl_${MY_PV}-$(ver_cut 5).debian.tar.xz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-${MY_PV}-as-needed.patch
+ "${FILESDIR}"/${PN}-${MY_PV}-ldflags.patch
+ "${FILESDIR}"/${PN}-${MY_PV}-implicit-function-declarations.patch
+)
+
+src_prepare() {
+ drop_debian_patch() {
+ rm "${WORKDIR}"/debian/patches/$1 || die
+ sed -i -e "/^${1}/d" "${WORKDIR}"/debian/patches/series || die
+ }
+
+ drop_debian_patch 000_soname_xlibs.diff
+
+ eapply $(awk '{print $1}' "${WORKDIR}"/debian/patches/series | sed -e "s:^:${WORKDIR}/debian/patches/:")
+
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}