summaryrefslogtreecommitdiff
path: root/dev-games/cegui/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-games/cegui/files
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-games/cegui/files')
-rw-r--r--dev-games/cegui/files/cegui-0.8.7-musl.patch72
-rw-r--r--dev-games/cegui/files/cegui-0.8.7-python3.patch21
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-games/cegui/files/cegui-0.8.7-musl.patch b/dev-games/cegui/files/cegui-0.8.7-musl.patch
new file mode 100644
index 000000000000..6eb62018dcfc
--- /dev/null
+++ b/dev-games/cegui/files/cegui-0.8.7-musl.patch
@@ -0,0 +1,72 @@
+From e7611d3ef0b9ab2e00f485030234dea3a58c7aa4 Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Sat, 16 May 2020 20:07:02 +0100
+Subject: [PATCH] Fix debug build and rework Exceptions includes logic
+
+Commit 3ddf92058392 broke the debug build. HAVE_EXECINFO_H is never
+defined by the build system so this header is never included, even
+when it is needed by the debug code.
+
+The right way to fix this is only to include these headers when debug
+is actually enabled. This does mean that the debug build is still
+broken under musl but fixing that would require using libunwind
+instead.
+---
+ cegui/src/Exceptions.cpp | 16 ++++------------
+ 1 file changed, 4 insertions(+), 12 deletions(-)
+
+diff --git a/cegui/src/Exceptions.cpp b/cegui/src/Exceptions.cpp
+index 138081a..934989e 100644
+--- a/cegui/src/Exceptions.cpp
++++ b/cegui/src/Exceptions.cpp
+@@ -33,12 +33,13 @@
+
+ #if defined( __WIN32__ ) || defined( _WIN32)
+ # include <windows.h>
++#elif defined(__ANDROID__)
++# include <android/log.h>
+ #endif
+
++#if defined(_DEBUG) || defined(DEBUG)
+ #if defined(_MSC_VER)
+ # include <dbghelp.h>
+-#elif defined(__ANDROID__)
+-# include <android/log.h>
+ #elif (defined(__linux__) && !defined(__ANDROID__)) \
+ || defined(__APPLE__) || defined(__FreeBSD__) || defined(__NetBSD__) \
+ || defined(__HAIKU__)
+@@ -47,6 +48,7 @@
+ # include <cxxabi.h>
+ # include <cstdlib>
+ #endif
++#endif
+
+ // Start of CEGUI namespace section
+ namespace CEGUI
+@@ -57,14 +59,6 @@ bool Exception::d_stdErrEnabled(true);
+ //----------------------------------------------------------------------------//
+ static void dumpBacktrace(size_t frames)
+ {
+-
+-#if defined(__ANDROID__)
+-
+- // Not implemented yet.
+- CEGUI_UNUSED(frames);
+-
+-#else
+-
+ #if defined(_DEBUG) || defined(DEBUG)
+ #if defined(_MSC_VER)
+ SymSetOptions(SYMOPT_DEFERRED_LOADS | SYMOPT_INCLUDE_32BIT_MODULES);
+@@ -187,8 +181,6 @@ static void dumpBacktrace(size_t frames)
+
+ CEGUI_UNUSED(frames);
+
+-#endif
+-
+ #endif
+ }
+
+--
+2.26.2
+
diff --git a/dev-games/cegui/files/cegui-0.8.7-python3.patch b/dev-games/cegui/files/cegui-0.8.7-python3.patch
new file mode 100644
index 000000000000..354f8cc65c8c
--- /dev/null
+++ b/dev-games/cegui/files/cegui-0.8.7-python3.patch
@@ -0,0 +1,21 @@
+From b53f162767bd18aa7dfebe322a7af65593c753f5 Mon Sep 17 00:00:00 2001
+From: ATAGOYAMA Tanuki <s172262@yahoo.co.jp>
+Date: Tue, 21 Nov 2017 20:51:36 +0900
+Subject: [PATCH] cegui/src/ScriptModules/Python/binding/CMakeLists.txt: fix
+ cmake error
+
+---
+ cegui/src/ScriptModules/Python/bindings/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cegui/src/ScriptModules/Python/bindings/CMakeLists.txt b/cegui/src/ScriptModules/Python/bindings/CMakeLists.txt
+index 758788c67..5cc9d5620 100644
+--- a/cegui/src/ScriptModules/Python/bindings/CMakeLists.txt
++++ b/cegui/src/ScriptModules/Python/bindings/CMakeLists.txt
+@@ -1,5 +1,5 @@
+ execute_process(
+- COMMAND ${PYTHON_EXECUTABLE} -c "import distutils.sysconfig; print distutils.sysconfig.get_python_lib(plat_specific=True, prefix=\"\")"
++ COMMAND ${PYTHON_EXECUTABLE} -c "import distutils.sysconfig; print (distutils.sysconfig.get_python_lib(plat_specific=True, prefix=\"\"))"
+ OUTPUT_VARIABLE CEGUI_PYTHON_INSTALL_DIR
+ OUTPUT_STRIP_TRAILING_WHITESPACE
+ )