summaryrefslogtreecommitdiff
path: root/dev-games/clanlib/clanlib-2.3.7-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-29 04:00:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-29 04:00:35 +0100
commit746652e918ce7328c0cc5ffef8a79146b91ba21b (patch)
tree755e0aa511453e24ffcf43e05e967e2268f56975 /dev-games/clanlib/clanlib-2.3.7-r3.ebuild
parent9c602d90d61cea9fe83c596c68a99e383ee15f73 (diff)
gentoo auto-resync : 29:10:2022 - 04:00:35
Diffstat (limited to 'dev-games/clanlib/clanlib-2.3.7-r3.ebuild')
-rw-r--r--dev-games/clanlib/clanlib-2.3.7-r3.ebuild119
1 files changed, 119 insertions, 0 deletions
diff --git a/dev-games/clanlib/clanlib-2.3.7-r3.ebuild b/dev-games/clanlib/clanlib-2.3.7-r3.ebuild
new file mode 100644
index 000000000000..d5d41ff83ea1
--- /dev/null
+++ b/dev-games/clanlib/clanlib-2.3.7-r3.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+MY_P=ClanLib-${PV}
+DESCRIPTION="Multi-platform game development library"
+HOMEPAGE="http://www.clanlib.org/"
+SRC_URI="http://clanlib.org/download/releases-2.0/${MY_P}.tgz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="ZLIB"
+SLOT="2.3"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ipv6 mikmod opengl sound sqlite cpu_flags_x86_sse2 static-libs vorbis X"
+REQUIRED_USE="opengl? ( X )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ dev-lang/perl
+ media-gfx/graphviz
+ )
+"
+RDEPEND="
+ sys-libs/zlib
+ X? (
+ app-arch/bzip2
+ media-libs/libpng:0
+ media-libs/freetype
+ media-libs/fontconfig
+ media-libs/libjpeg-turbo:0=
+ x11-libs/libX11
+ opengl? ( virtual/opengl )
+ )
+ mikmod? (
+ media-libs/alsa-lib
+ media-libs/libmikmod
+ )
+ sqlite? ( dev-db/sqlite:3 )
+ sound? ( media-libs/alsa-lib )
+ vorbis? (
+ media-libs/alsa-lib
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-doc.patch
+ "${FILESDIR}"/${P}-freetype_pkgconfig.patch #764902
+ "${FILESDIR}"/${P}-glibc2.34.patch
+ "${FILESDIR}"/${P}-32bit-opengl.patch
+ # From Fedora
+ "${FILESDIR}"/${P}-gcc47.patch
+ "${FILESDIR}"/${P}-gcc7.patch
+ "${FILESDIR}"/${P}-non-x86.patch
+ "${FILESDIR}"/${P}-no-ldflags-for-conftest.patch
+ "${FILESDIR}"/${P}-no-wm_type-in-fs.patch
+)
+
+DOCS=( CODING_STYLE CREDITS PATCHES README )
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ ln -sf ../../../Sources/API Documentation/Utilities/ReferenceDocs/ClanLib || die
+}
+
+src_configure() {
+ # Add -DPACKAGE_BUGREPORT?
+ local myeconfargs=(
+ $(use_enable doc docs)
+ $(use_enable cpu_flags_x86_sse2 sse2)
+ $(use_enable opengl clanGL)
+ $(use_enable opengl clanGL1)
+ $(use_enable opengl clanGUI)
+ $(use_enable X clanDisplay)
+ $(use_enable vorbis clanVorbis)
+ $(use_enable mikmod clanMikMod)
+ $(use_enable sqlite clanSqlite)
+ $(use_enable ipv6 getaddr)
+ )
+
+ use sound \
+ || use vorbis \
+ || use mikmod \
+ || myeconfargs+=( --disable-clanSound )
+
+ tc-export PKG_CONFIG
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+
+ use doc && emake html
+}
+
+# html files are keeped in a directory that is dependent on the SLOT
+# so to keep eventual bookmarks to the doc from version to version
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+
+ if use doc ; then
+ emake DESTDIR="${D}" install-html
+ dodoc -r Examples Resources
+ fi
+}