summaryrefslogtreecommitdiff
path: root/dev-games/clanlib/clanlib-4.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-games/clanlib/clanlib-4.0.0.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-games/clanlib/clanlib-4.0.0.ebuild')
-rw-r--r--dev-games/clanlib/clanlib-4.0.0.ebuild79
1 files changed, 0 insertions, 79 deletions
diff --git a/dev-games/clanlib/clanlib-4.0.0.ebuild b/dev-games/clanlib/clanlib-4.0.0.ebuild
deleted file mode 100644
index cc7115a38348..000000000000
--- a/dev-games/clanlib/clanlib-4.0.0.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-MY_PN=ClanLib
-
-DESCRIPTION="Multi-platform game development library"
-HOMEPAGE="https://github.com/sphair/ClanLib"
-SRC_URI="https://github.com/sphair/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="4.0"
-KEYWORDS="~amd64 ~x86" #not big endian safe #82779
-IUSE="cpu_flags_x86_sse2 doc examples ipv6 opengl sound static-libs X"
-REQUIRED_USE="opengl? ( X )"
-
-RDEPEND="
- sys-libs/zlib
- X? (
- media-libs/freetype:2
- media-libs/fontconfig
- x11-libs/libX11
- opengl? (
- virtual/opengl
- x11-libs/libXrender
- )
- )
- sound? ( media-libs/alsa-lib )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? (
- app-doc/doxygen
- dev-lang/perl
- media-gfx/graphviz
- )"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.0.0-fix-build-system.patch
- "${FILESDIR}"/${PN}-4.0.0-freetype_pkgconfig.patch #658424
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable doc docs)
- $(use_enable cpu_flags_x86_sse2 sse2)
- $(use_enable opengl clanGL)
- $(use_enable opengl clanUI)
- $(use_enable X clanDisplay)
- $(use_enable sound clanSound)
- $(use_enable ipv6 getaddr)
- $(use_enable static-libs static)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- default
- use doc && emake html
-}
-
-src_install() {
- default
-
- use doc && emake DESTDIR="${D}" install-html
- use examples && dodoc -r Examples Resources
-
- # package provides .pc files
- find "${ED}" -name '*.la' -delete || die
-}