summaryrefslogtreecommitdiff
path: root/dev-games/clanlib/clanlib-4.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /dev-games/clanlib/clanlib-4.0.0.ebuild
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'dev-games/clanlib/clanlib-4.0.0.ebuild')
-rw-r--r--dev-games/clanlib/clanlib-4.0.0.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/dev-games/clanlib/clanlib-4.0.0.ebuild b/dev-games/clanlib/clanlib-4.0.0.ebuild
index 310134a70f44..cc7115a38348 100644
--- a/dev-games/clanlib/clanlib-4.0.0.ebuild
+++ b/dev-games/clanlib/clanlib-4.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -37,10 +37,11 @@ DEPEND="${RDEPEND}
media-gfx/graphviz
)"
-S=${WORKDIR}/${MY_PN}-${PV}
+S="${WORKDIR}/${MY_PN}-${PV}"
PATCHES=(
"${FILESDIR}"/${PN}-4.0.0-fix-build-system.patch
+ "${FILESDIR}"/${PN}-4.0.0-freetype_pkgconfig.patch #658424
)
src_prepare() {
@@ -49,15 +50,17 @@ src_prepare() {
}
src_configure() {
- econf \
- $(use_enable doc docs) \
- $(use_enable cpu_flags_x86_sse2 sse2) \
- $(use_enable opengl clanGL) \
- $(use_enable opengl clanUI) \
- $(use_enable X clanDisplay) \
- $(use_enable sound clanSound) \
- $(use_enable ipv6 getaddr) \
+ local myeconfargs=(
+ $(use_enable doc docs)
+ $(use_enable cpu_flags_x86_sse2 sse2)
+ $(use_enable opengl clanGL)
+ $(use_enable opengl clanUI)
+ $(use_enable X clanDisplay)
+ $(use_enable sound clanSound)
+ $(use_enable ipv6 getaddr)
$(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
}
src_compile() {
@@ -72,5 +75,5 @@ src_install() {
use examples && dodoc -r Examples Resources
# package provides .pc files
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}