summaryrefslogtreecommitdiff
path: root/dev-games/guichan/guichan-0.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-games/guichan/guichan-0.8.2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-games/guichan/guichan-0.8.2.ebuild')
-rw-r--r--dev-games/guichan/guichan-0.8.2.ebuild32
1 files changed, 20 insertions, 12 deletions
diff --git a/dev-games/guichan/guichan-0.8.2.ebuild b/dev-games/guichan/guichan-0.8.2.ebuild
index 049a09d0547b..3c7dbd3c59ff 100644
--- a/dev-games/guichan/guichan-0.8.2.ebuild
+++ b/dev-games/guichan/guichan-0.8.2.ebuild
@@ -1,30 +1,37 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils autotools ltprune
+EAPI=7
-DESCRIPTION="a portable C++ GUI library designed for games using Allegro, SDL and/or OpenGL"
+inherit autotools
+
+DESCRIPTION="A portable C++ GUI library designed for games using Allegro, SDL and/or OpenGL"
HOMEPAGE="http://guichan.sourceforge.net/"
SRC_URI="https://guichan.googlecode.com/files/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="allegro opengl sdl static-libs"
+IUSE="allegro opengl sdl"
-DEPEND="allegro? ( <media-libs/allegro-5 )
+DEPEND="
+ allegro? ( media-libs/allegro:0 )
opengl? ( virtual/opengl )
sdl? (
media-libs/libsdl
media-libs/sdl-image
)"
-RDEPEND=${DEPEND}
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-automake-1.13.patch
+ "${FILESDIR}"/${P}-slibtool-undefined-references.patch
+)
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-as-needed.patch \
- "${FILESDIR}"/${P}-automake-1.13.patch
+ default
+
mv configure.in configure.ac || die
eautoreconf
}
@@ -35,10 +42,11 @@ src_configure() {
$(use_enable opengl) \
$(use_enable sdl) \
$(use_enable sdl sdlimage) \
- $(use_enable static-libs static)
+ --disable-static
}
src_install() {
default
- prune_libtool_files
+
+ find "${ED}" -name '*.la' -delete || die
}