summaryrefslogtreecommitdiff
path: root/dev-games/guichan/guichan-0.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-games/guichan/guichan-0.8.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-games/guichan/guichan-0.8.2.ebuild')
-rw-r--r--dev-games/guichan/guichan-0.8.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-games/guichan/guichan-0.8.2.ebuild b/dev-games/guichan/guichan-0.8.2.ebuild
new file mode 100644
index 000000000000..16a681c1f6e5
--- /dev/null
+++ b/dev-games/guichan/guichan-0.8.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="a portable C++ GUI library designed for games using Allegro, SDL and/or OpenGL"
+HOMEPAGE="http://guichan.sourceforge.net/"
+SRC_URI="https://guichan.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="allegro opengl sdl static-libs"
+
+DEPEND="allegro? ( <media-libs/allegro-5 )
+ opengl? ( virtual/opengl )
+ sdl? (
+ media-libs/libsdl
+ media-libs/sdl-image
+ )"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-automake-1.13.patch
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable allegro) \
+ $(use_enable opengl) \
+ $(use_enable sdl) \
+ $(use_enable sdl sdlimage) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}