summaryrefslogtreecommitdiff
path: root/dev-games/mygui
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-games/mygui
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-games/mygui')
-rw-r--r--dev-games/mygui/Manifest6
-rw-r--r--dev-games/mygui/files/mygui-3.2.2-FHS.patch44
-rw-r--r--dev-games/mygui/files/mygui-3.2.2-build.patch61
-rw-r--r--dev-games/mygui/files/mygui-3.2.2-underlinking.patch20
-rw-r--r--dev-games/mygui/metadata.xml47
-rw-r--r--dev-games/mygui/mygui-3.2.2.ebuild142
6 files changed, 320 insertions, 0 deletions
diff --git a/dev-games/mygui/Manifest b/dev-games/mygui/Manifest
new file mode 100644
index 000000000000..cc0f097e2858
--- /dev/null
+++ b/dev-games/mygui/Manifest
@@ -0,0 +1,6 @@
+AUX mygui-3.2.2-FHS.patch 1209 BLAKE2B 7bd14cfe0653ac74df4ab5ac6be69a9d95837795820baf5e0e6a11a03448f57cf761f240d3fa62e2f1ef121ac2e9b48b802edf74905fdf68f6744773f612cbe9 SHA512 21aba7d654a7197423bdeaa06fa79219d850c76248546227ece1f4916072289f0ebf68a9ad9a4569a1d5dfc15cf86762db3c0d4d58f4c233c1b4293ffb35e50e
+AUX mygui-3.2.2-build.patch 2801 BLAKE2B c414f7249f63c5addd0c616df3a0ac0979fc7c8565b9c12c8f81007f152c129d868ec9359641ce59abca4b9958bc3fa39bb906b221d66fef4e9df53135bf18da SHA512 954f95759967a1a4f4eb6952f6abbabbe3157703d5d0014299a8cd5060cd5fb0c7faa635ad10e5c23e0bc0c8d8089c29c14952058a7bdcc2643f06c226f5524d
+AUX mygui-3.2.2-underlinking.patch 398 BLAKE2B 0e4ebdf58228ac6b6368202c40137feadf5f3adeb4f2e20020d2ed8db6db17a1ca0715e1018a5e851cc8a38163e4607e9f705f20f3190fa09de9de0eb7ab3099 SHA512 ad0e5e0e8aacdb65ea9195175f597eb95f265b07d0154482f2380ae6e837672d5d41b6d43b1266abb12dec319625426dd65a892aca7fdca297131bd4db2312b9
+DIST MyGUI3.2.2.tar.gz 22081236 BLAKE2B 3a28e0838a8203d20565822d5a19423a733149cca250dc4169de43f22beb7d37fccbf3d282ea9b4f284cb71df2df9a9073bac40124e1d8a90d15c5fda2af798a SHA512 1290ce1d78b9e4bfe72bea3fb1bc6cdd25969b44be2844df62a1f425b3e221a68b61658fdf45271fb50a1957f12b5ada1c9be971e00ecfe41f53ae0a83ae18d4
+EBUILD mygui-3.2.2.ebuild 3709 BLAKE2B 7052d559043cf9d8804c2ed98fd11fbfb810ad9e6c59a21e238ed60055efee58d57f3925814639f799a47efcc4e79102653f0174275f0b96987bfb2ccdee6ccd SHA512 78127dd2d71ca2a84428264a70be3101e4684f50b1319bbb0a3d14abe1536262e247677dcbe9bce1a96357e8d8e3bb1afc72d7b20831460ab54203738d7c32a9
+MISC metadata.xml 2039 BLAKE2B d2e8e5e47ddac57da0258a24d00660328998fb34b806d07d1ae7119027fd850c275511ada20943eb27cb8eef22a225781e3e88d5be8ff98684372889ad1d4518 SHA512 35efd58650be9ea1108ae98b5e67d5740d26d831475faca21a3587607396cb9466b93047ebe129d0b3bbf77f3e23d52064d6a1a65b344943fba54f940326af22
diff --git a/dev-games/mygui/files/mygui-3.2.2-FHS.patch b/dev-games/mygui/files/mygui-3.2.2-FHS.patch
new file mode 100644
index 000000000000..14d21626ff7b
--- /dev/null
+++ b/dev-games/mygui/files/mygui-3.2.2-FHS.patch
@@ -0,0 +1,44 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sat Oct 27 22:39:31 UTC 2012
+Subject: FHS
+
+paths hardcoded until upstream fixed the logic
+
+--- mygui-MyGUI3.2.2.orig/CMake/InstallResources.cmake
++++ mygui-MyGUI3.2.2/CMake/InstallResources.cmake
+@@ -24,7 +24,7 @@
+ else ()
+ install(FILES
+ ${MYGUI_BINARY_DIR}/bin/${FILENAME}
+- DESTINATION "bin"
++ DESTINATION "/etc/MYGUI"
+ )
+ endif ()
+ endfunction(install_file)
+@@ -53,7 +53,7 @@
+ if (WIN32)
+ set(MYGUI_MEDIA_DIR "../../Media")
+ elseif (UNIX)
+- set(MYGUI_MEDIA_DIR "../share/MYGUI/Media")
++ set(MYGUI_MEDIA_DIR "${CMAKE_INSTALL_PREFIX}/share/MYGUI/Media")
+ else ()
+ set(MYGUI_MEDIA_DIR "../../Media")
+ endif ()
+--- mygui-MyGUI3.2.2.orig/Common/Base/Ogre/BaseManager.cpp
++++ mygui-MyGUI3.2.2/Common/Base/Ogre/BaseManager.cpp
+@@ -49,13 +49,13 @@
+ mWindow(nullptr),
+ mExit(false),
+ mPluginCfgName("plugins.cfg"),
+- mResourceXMLName("resources.xml"),
++ mResourceXMLName("/etc/MYGUI/resources.xml"),
+ mResourceFileName("MyGUI_Core.xml")
+ {
+ #if MYGUI_PLATFORM == MYGUI_PLATFORM_APPLE
+ mResourcePath = macBundlePath() + "/Contents/Resources/";
+ #else
+- mResourcePath = "";
++ mResourcePath = "/etc/MYGUI/";
+ #endif
+ }
+
diff --git a/dev-games/mygui/files/mygui-3.2.2-build.patch b/dev-games/mygui/files/mygui-3.2.2-build.patch
new file mode 100644
index 000000000000..a16b27c285b7
--- /dev/null
+++ b/dev-games/mygui/files/mygui-3.2.2-build.patch
@@ -0,0 +1,61 @@
+diff -ru mygui-MyGUI3.2.2.orig/CMake/ConfigureBuild.cmake mygui-MyGUI3.2.2/CMake/ConfigureBuild.cmake
+--- mygui-MyGUI3.2.2.orig/CMake/ConfigureBuild.cmake 2015-01-26 10:32:35.000000000 -0500
++++ mygui-MyGUI3.2.2/CMake/ConfigureBuild.cmake 2015-03-14 01:09:40.743621643 -0400
+@@ -4,6 +4,8 @@
+ # also prepare package files for pkg-config and CMake.
+ #######################################################################
+
++include(GNUInstallDirs)
++
+ # should we build static libs?
+ if (MYGUI_STATIC)
+ set(MYGUI_LIB_TYPE STATIC)
+@@ -47,7 +49,7 @@
+ else ()
+ configure_file(${MYGUI_TEMPLATES_DIR}/MYGUI.pc.in ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc @ONLY)
+ endif ()
+- install(FILES ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc DESTINATION lib/pkgconfig)
++ install(FILES ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+
+ # configure additional packages
+
+diff -ru mygui-MyGUI3.2.2.orig/CMake/Utils/MyGUIConfigTargets.cmake mygui-MyGUI3.2.2/CMake/Utils/MyGUIConfigTargets.cmake
+--- mygui-MyGUI3.2.2.orig/CMake/Utils/MyGUIConfigTargets.cmake 2015-01-26 10:32:35.000000000 -0500
++++ mygui-MyGUI3.2.2/CMake/Utils/MyGUIConfigTargets.cmake 2015-03-14 01:08:44.905791784 -0400
+@@ -1,6 +1,8 @@
+ # Configure settings and install targets
+ # FIXME: Copypasted from Ogre and need lots of changes
+
++include(GNUInstallDirs)
++
+ if (WIN32)
+ set(MYGUI_RELEASE_PATH "/Release")
+ set(MYGUI_RELWDBG_PATH "/RelWithDebInfo")
+@@ -60,6 +62,12 @@
+ # install targets according to current build type
+ function(mygui_install_target TARGETNAME SUFFIX)
+ install(TARGETS ${TARGETNAME}
++ RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}" CONFIGURATIONS Gentoo ""
++ LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}" CONFIGURATIONS Gentoo ""
++ ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}" CONFIGURATIONS Gentoo ""
++ FRAMEWORK DESTINATION "${MYGUI_FRAMEWORK_PATH}" CONFIGURATIONS Gentoo ""
++ )
++ install(TARGETS ${TARGETNAME}
+ RUNTIME DESTINATION "bin${MYGUI_RELEASE_PATH}" CONFIGURATIONS Release None ""
+ LIBRARY DESTINATION "lib${MYGUI_LIB_RELEASE_PATH}${SUFFIX}" CONFIGURATIONS Release None ""
+ ARCHIVE DESTINATION "lib${MYGUI_LIB_RELEASE_PATH}${SUFFIX}" CONFIGURATIONS Release None ""
+@@ -171,7 +179,13 @@
+ endif ()
+ add_executable(${PROJECTNAME} ${MYGUI_EXEC_TYPE} ${HEADER_FILES} ${SOURCE_FILES})
+ endif ()
+- set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER})
++
++ # rename demo target^M
++ if (${SOLUTIONFOLDER} STREQUAL "Demos")
++ set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER} OUTPUT_NAME MYGUI-${PROJECTNAME})
++ else()
++ set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER})
++ endif()
+
+ add_dependencies(${PROJECTNAME} MyGUIEngine Common)
+
diff --git a/dev-games/mygui/files/mygui-3.2.2-underlinking.patch b/dev-games/mygui/files/mygui-3.2.2-underlinking.patch
new file mode 100644
index 000000000000..2d1026856f03
--- /dev/null
+++ b/dev-games/mygui/files/mygui-3.2.2-underlinking.patch
@@ -0,0 +1,20 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri Jun 15 10:42:42 UTC 2012
+Subject: build system
+
+fix underlinking
+
+--- MyGUIEngine/CMakeLists.txt
++++ MyGUIEngine/CMakeLists.txt
+@@ -48,7 +48,10 @@
+ if (MYGUI_USE_FREETYPE)
+ target_link_libraries(${PROJECTNAME}
+ ${FREETYPE_LIBRARIES}
+- )
++ dl)
++else()
++ target_link_libraries(${PROJECTNAME}
++ dl)
+ endif()
+
+ # platform specific dependencies
diff --git a/dev-games/mygui/metadata.xml b/dev-games/mygui/metadata.xml
new file mode 100644
index 000000000000..0b17cdd092c3
--- /dev/null
+++ b/dev-games/mygui/metadata.xml
@@ -0,0 +1,47 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>altren@list.ru</email>
+ <name>Evmenov Georgiy</name>
+ </maintainer>
+ <changelog>http://redmine.mygui.info/repositories/entry/mygui/tags/MyGUI3.2/ChangeLog.txt</changelog>
+ <bugs-to>https://sourceforge.net/tracker/?group_id=193706&amp;atid=946487</bugs-to>
+ <remote-id type="github">MyGUI/mygui</remote-id>
+ </upstream>
+ <use>
+ <flag name="l10n_ru">Install some additional russian docs if 'doc' useflag enabled</flag>
+ <flag name="opengl">Use the opengl render subsystem. (cannot combine with ogre)</flag>
+ <flag name="ogre">Use the ogre render subsystem. (cannot combine with opengl)</flag>
+ <flag name="plugins">Build MyGUI plugins</flag>
+ <flag name="samples">Install MyGUI demos (needs ogre USE flag)</flag>
+ <flag name="tools">Build the tools for development</flag>
+ </use>
+ <longdescription lang="en">
+ MyGUI is a library for creating Graphical User Interfaces (GUIs) for
+ games and 3D applications. The main goals of mygui are: speed,
+ flexibility and ease of use.
+
+ Speed
+ We speed up our system by using our own batching subsystem which
+ combines geometry. It is also possible for the more experienced
+ developers to write their own render system or new subsystems
+
+ Flexibility
+ The library supports plugins that allows you to create dynamically
+ loaded custom controls or subsystems. Most subsystems are expandable
+ with plugins without the need to touch the core code. All resources
+ and settings are described in XML files. It is possible to load
+ resources like fonts, cursors, images, skins, etc. Forms (layouts)
+ via dynamically by using XML files.
+
+ Simplicity
+ The user interface is easy to use and uses delegates (Signals and
+ slots) for easy to use event handling.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-games/mygui/mygui-3.2.2.ebuild b/dev-games/mygui/mygui-3.2.2.ebuild
new file mode 100644
index 000000000000..fad4ba2881d6
--- /dev/null
+++ b/dev-games/mygui/mygui-3.2.2.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CMAKE_REMOVE_MODULES="yes"
+CMAKE_REMOVE_MODULES_LIST="FindFreetype"
+inherit eutils cmake-utils flag-o-matic multilib
+
+MY_PN=MyGUI
+MY_P=${MY_PN}${PV}
+
+DESCRIPTION="A library for creating GUIs for games"
+HOMEPAGE="http://mygui.info/"
+SRC_URI="https://github.com/MyGUI/mygui/archive/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug doc +ogre -opengl plugins samples static-libs test tools l10n_ru"
+REQUIRED_USE="ogre? ( !opengl )
+ opengl? ( !ogre )"
+
+RDEPEND="
+ media-libs/freetype:2
+ ogre? (
+ dev-games/ogre:=[freeimage,opengl]
+ samples? ( dev-games/ois )
+ )
+ opengl? ( virtual/opengl
+ media-libs/glew )
+ tools? ( dev-games/ois )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/mygui-${MY_P}
+STATIC_BUILD=${WORKDIR}/${P}_build_static
+
+PATCHES=(
+ "${FILESDIR}"/${P}-underlinking.patch
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-FHS.patch
+)
+
+pkg_setup() {
+ if use samples && use !ogre ; then
+ ewarn "Samples disabled, because they only work with ogre!"
+ ewarn "Enable ogre USE flag if you want to use samples."
+ fi
+}
+
+src_configure() {
+ use debug && append-cppflags -DDEBUG
+
+ local mycmakeargs=()
+
+ # static configuration
+ if use static-libs ; then
+ mycmakeargs=( -DMYGUI_STATIC=ON
+ -DMYGUI_BUILD_DOCS=OFF
+ -DMYGUI_INSTALL_DOCS=OFF
+ -DMYGUI_USE_FREETYPE=ON
+ $(cmake-utils_use plugins MYGUI_BUILD_PLUGINS)
+ -DMYGUI_BUILD_DEMOS=OFF
+ -DMYGUI_INSTALL_SAMPLES=OFF
+ -DMYGUI_BUILD_TOOLS=OFF
+ -DMYGUI_INSTALL_TOOLS=OFF
+ -DMYGUI_BUILD_WRAPPER=OFF
+ -DMYGUI_RENDERSYSTEM=$(usex opengl "4" "$(usex ogre "3" "1")") )
+
+ CMAKE_BUILD_DIR=${STATIC_BUILD} cmake-utils_src_configure
+ unset mycmakeargs
+ fi
+
+ # main configuration
+ mycmakeargs=( -DMYGUI_STATIC=OFF
+ $(cmake-utils_use doc MYGUI_BUILD_DOCS)
+ $(cmake-utils_use doc MYGUI_INSTALL_DOCS)
+ -DMYGUI_USE_FREETYPE=ON
+ $(cmake-utils_use plugins MYGUI_BUILD_PLUGINS)
+ $(usex ogre "$(cmake-utils_use samples MYGUI_BUILD_DEMOS)" "-DMYGUI_BUILD_DEMOS=OFF")
+ $(usex ogre "$(cmake-utils_use samples MYGUI_INSTALL_SAMPLES)" "-DMYGUI_INSTALL_SAMPLES=OFF")
+ $(cmake-utils_use tools MYGUI_BUILD_TOOLS)
+ $(cmake-utils_use tools MYGUI_INSTALL_TOOLS)
+ $(cmake-utils_use opengl MYGUI_USE_SYSTEM_GLEW)
+ -DMYGUI_BUILD_WRAPPER=OFF
+ -DMYGUI_RENDERSYSTEM=$(usex opengl "4" "$(usex ogre "3" "1")") )
+
+ if use tools || (use samples && use ogre) ; then
+ mycmakeargs+=( -DMYGUI_INSTALL_MEDIA=ON )
+ else
+ mycmakeargs+=( -DMYGUI_INSTALL_MEDIA=OFF )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ # build system does not support building static and shared at once,
+ # run a double build
+ if use static-libs ; then
+ CMAKE_BUILD_DIR=${STATIC_BUILD} cmake-utils_src_compile
+ fi
+
+ cmake-utils_src_compile
+
+ use doc && emake -C "${CMAKE_BUILD_DIR}"/Docs api-docs
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use static-libs ; then
+ find "${STATIC_BUILD}" -name "*.a" \! -name "libCommon.a" -exec dolib.a '{}' \;
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins "${STATIC_BUILD}"/pkgconfig/MYGUIStatic.pc
+ fi
+
+ if use doc ; then
+ dohtml -r "${CMAKE_BUILD_DIR}"/Docs/html/*
+
+ if use l10n_ru ; then
+ docompress -x /usr/share/doc/${PF}/Papers
+ dodoc -r Docs/Papers
+ fi
+ fi
+
+ keepdir /etc/MYGUI
+ fperms o+w /etc/MYGUI
+
+ # test media not needed at runtime
+ rm -rf "${ED%/}"/usr/share/MYGUI/Media/UnitTests || die
+ # wrapper not available for linux, remove related media
+ rm -rf "${ED%/}"/usr/share/MYGUI/Media/Wrapper || die
+}
+
+pkg_postinst() {
+ elog
+ elog "ogre.cfg and Ogre.log are created as"
+ elog "${EROOT%/}/etc/MYGUI/mygui-ogre.cfg and /etc/MYGUI/mygui-Ogre.log"
+ elog
+}