summaryrefslogtreecommitdiff
path: root/dev-games/newton/newton-3.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-games/newton/newton-3.14.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-games/newton/newton-3.14.ebuild')
-rw-r--r--dev-games/newton/newton-3.14.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/dev-games/newton/newton-3.14.ebuild b/dev-games/newton/newton-3.14.ebuild
index ef27f047fc4d..f1e04a4e16d0 100644
--- a/dev-games/newton/newton-3.14.ebuild
+++ b/dev-games/newton/newton-3.14.ebuild
@@ -1,28 +1,25 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils toolchain-funcs
+inherit cmake
MY_P="${PN}-dynamics-${P}"
DESCRIPTION="Integrated solution for real time simulation of physics environments"
HOMEPAGE="http://newtondynamics.com/forum/newton.php"
SRC_URI="https://github.com/MADEAPPS/newton-dynamics/archive/${P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-RDEPEND=""
DEPEND="dev-libs/tinyxml"
-S=${WORKDIR}/${MY_P}
-
src_prepare() {
- cmake-utils_src_prepare
sed -i -e '/packages/d' CMakeLists.txt || die
+ cmake_src_prepare
}
src_configure() {
@@ -30,5 +27,5 @@ src_configure() {
-DNEWTON_DEMOS_SANDBOX=OFF
-DCMAKE_VERBOSE_MAKEFILE=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}