summaryrefslogtreecommitdiff
path: root/dev-games/ois/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-games/ois/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-games/ois/files')
-rw-r--r--dev-games/ois/files/ois-1.3-automake-1.13.patch11
-rw-r--r--dev-games/ois/files/ois-1.3-gcc47.patch40
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-games/ois/files/ois-1.3-automake-1.13.patch b/dev-games/ois/files/ois-1.3-automake-1.13.patch
new file mode 100644
index 000000000000..fb103e40335a
--- /dev/null
+++ b/dev-games/ois/files/ois-1.3-automake-1.13.patch
@@ -0,0 +1,11 @@
+--- ois-v1-3/configure.ac
++++ ois-v1-3/configure.ac
+@@ -5,7 +5,7 @@
+
+ AC_CANONICAL_TARGET
+ AM_INIT_AUTOMAKE( [OIS], 1.3.0 )
+-AM_CONFIG_HEADER([includes/config.h])
++AC_CONFIG_HEADERS([includes/config.h])
+
+ dnl Check for programs
+ AC_PROG_CC
diff --git a/dev-games/ois/files/ois-1.3-gcc47.patch b/dev-games/ois/files/ois-1.3-gcc47.patch
new file mode 100644
index 000000000000..d002ec3cffb5
--- /dev/null
+++ b/dev-games/ois/files/ois-1.3-gcc47.patch
@@ -0,0 +1,40 @@
+--- demos/FFConsoleDemo.cpp.old 2012-07-17 08:41:33.667876985 +0200
++++ demos/FFConsoleDemo.cpp 2012-07-17 08:42:01.415928693 +0200
+@@ -7,6 +7,7 @@
+ #include <ios>
+ #include <sstream>
+ #include <vector>
++#include <unistd.h>
+
+ using namespace std;
+
+--- demos/OISConsole.cpp.old 2012-07-17 08:43:44.637681119 +0200
++++ demos/OISConsole.cpp 2012-07-17 08:44:06.653135337 +0200
+@@ -12,6 +12,7 @@
+ #include <iostream>
+ #include <vector>
+ #include <sstream>
++#include <unistd.h>
+
+ ////////////////////////////////////Needed Windows Headers////////////
+ #if defined OIS_WIN32_PLATFORM
+--- src/linux/LinuxJoyStickEvents.cpp.old 2012-07-17 08:37:56.065155660 +0200
++++ src/linux/LinuxJoyStickEvents.cpp 2012-07-17 08:38:33.236545721 +0200
+@@ -33,6 +33,7 @@
+ #include <fcntl.h> //Needed to Open a file descriptor
+ #include <cassert>
+ #include <linux/input.h>
++#include <unistd.h>
+
+
+ #include <sstream>
+--- src/linux/LinuxForceFeedback.cpp.old 2012-07-17 08:40:02.633268854 +0200
++++ src/linux/LinuxForceFeedback.cpp 2012-07-17 08:40:28.642442655 +0200
+@@ -26,6 +26,7 @@
+ #include <cstdlib>
+ #include <errno.h>
+ #include <memory.h>
++#include <unistd.h>
+
+ using namespace OIS;
+