summaryrefslogtreecommitdiff
path: root/dev-games/quake4-sdk/quake4-sdk-1.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-games/quake4-sdk/quake4-sdk-1.4.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-games/quake4-sdk/quake4-sdk-1.4.2.ebuild')
-rw-r--r--dev-games/quake4-sdk/quake4-sdk-1.4.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-games/quake4-sdk/quake4-sdk-1.4.2.ebuild b/dev-games/quake4-sdk/quake4-sdk-1.4.2.ebuild
new file mode 100644
index 000000000000..508f8172267c
--- /dev/null
+++ b/dev-games/quake4-sdk/quake4-sdk-1.4.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit unpacker games
+
+DESCRIPTION="Quake4 SDK"
+HOMEPAGE="http://www.iddevnet.com/quake4/"
+SRC_URI="mirror://idsoftware/quake4/source/linux/quake4-linux-${PV}-sdk.x86.run"
+
+LICENSE="QUAKE4"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="strip"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_makeself
+ rm -rf setup.{sh,data} || die
+}
+
+src_install() {
+ insinto "${GAMES_PREFIX_OPT}/${PN}"
+ doins -r *
+ prepgamesdirs
+}