summaryrefslogtreecommitdiff
path: root/dev-games/quake4-sdk/quake4-sdk-1.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-games/quake4-sdk/quake4-sdk-1.4.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-games/quake4-sdk/quake4-sdk-1.4.2.ebuild')
-rw-r--r--dev-games/quake4-sdk/quake4-sdk-1.4.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-games/quake4-sdk/quake4-sdk-1.4.2.ebuild b/dev-games/quake4-sdk/quake4-sdk-1.4.2.ebuild
new file mode 100644
index 000000000000..4d98a6595544
--- /dev/null
+++ b/dev-games/quake4-sdk/quake4-sdk-1.4.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit unpacker games
+
+DESCRIPTION="Quake4 SDK"
+HOMEPAGE="https://www.iddevnet.com/quake4/"
+SRC_URI="mirror://idsoftware/quake4/source/linux/quake4-linux-${PV}-sdk.x86.run"
+
+LICENSE="QUAKE4"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="strip"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_makeself
+ rm -rf setup.{sh,data} || die
+}
+
+src_install() {
+ insinto "${GAMES_PREFIX_OPT}/${PN}"
+ doins -r *
+ prepgamesdirs
+}