summaryrefslogtreecommitdiff
path: root/dev-games/recastnavigation/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-14 23:53:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-14 23:53:26 +0000
commit3bd85407abc9ed4434c2d3741f84fdb512638b1c (patch)
tree15a296c276aca23d87cb4f2181f2249d706ca05f /dev-games/recastnavigation/files
parenta90c84e720803f3d26c0ade8f1f1e405ca97502a (diff)
gentoo auto-resync : 14:01:2023 - 23:53:26
Diffstat (limited to 'dev-games/recastnavigation/files')
-rw-r--r--dev-games/recastnavigation/files/recastnavigation-1.5.1_p20230102-catch.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/dev-games/recastnavigation/files/recastnavigation-1.5.1_p20230102-catch.patch b/dev-games/recastnavigation/files/recastnavigation-1.5.1_p20230102-catch.patch
new file mode 100644
index 000000000000..5b0ff9bc6017
--- /dev/null
+++ b/dev-games/recastnavigation/files/recastnavigation-1.5.1_p20230102-catch.patch
@@ -0,0 +1,10 @@
+--- a/Tests/CMakeLists.txt
++++ b/Tests/CMakeLists.txt
+@@ -10,5 +10,6 @@ add_executable(Tests ${TESTS_SOURCES})
+ set_property(TARGET Tests PROPERTY CXX_STANDARD 17)
+
+ add_dependencies(Tests Recast Detour)
+-target_link_libraries(Tests Recast Detour)
++find_package(Catch2 REQUIRED)
++target_link_libraries(Tests Recast Detour Catch2::Catch2WithMain)
+ add_test(Tests Tests)