summaryrefslogtreecommitdiff
path: root/dev-games/wfmath/wfmath-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-games/wfmath/wfmath-1.0.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-games/wfmath/wfmath-1.0.2.ebuild')
-rw-r--r--dev-games/wfmath/wfmath-1.0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-games/wfmath/wfmath-1.0.2.ebuild b/dev-games/wfmath/wfmath-1.0.2.ebuild
new file mode 100644
index 000000000000..096663843a6f
--- /dev/null
+++ b/dev-games/wfmath/wfmath-1.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Worldforge math library"
+HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/wfmath"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ use doc && emake -C doc docs
+}
+
+src_install() {
+ default
+ use doc && dohtml doc/html/*
+ prune_libtool_files
+}