summaryrefslogtreecommitdiff
path: root/dev-games/wfmath/wfmath-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-games/wfmath/wfmath-1.0.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-games/wfmath/wfmath-1.0.2.ebuild')
-rw-r--r--dev-games/wfmath/wfmath-1.0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-games/wfmath/wfmath-1.0.2.ebuild b/dev-games/wfmath/wfmath-1.0.2.ebuild
new file mode 100644
index 000000000000..096663843a6f
--- /dev/null
+++ b/dev-games/wfmath/wfmath-1.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Worldforge math library"
+HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/wfmath"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ use doc && emake -C doc docs
+}
+
+src_install() {
+ default
+ use doc && dohtml doc/html/*
+ prune_libtool_files
+}