summaryrefslogtreecommitdiff
path: root/dev-gap/cohomolo/cohomolo-1.6.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-22 16:48:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-22 16:48:54 +0000
commitce163dcd0944d81d8406c9532b457535efca7a6d (patch)
treef7deea170544ce69e03c037101b7b5c1277966b4 /dev-gap/cohomolo/cohomolo-1.6.11.ebuild
parent05ee8049e2326946a2cd1720f98384c864f0a804 (diff)
gentoo auto-resync : 22:01:2024 - 16:48:54
Diffstat (limited to 'dev-gap/cohomolo/cohomolo-1.6.11.ebuild')
-rw-r--r--dev-gap/cohomolo/cohomolo-1.6.11.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-gap/cohomolo/cohomolo-1.6.11.ebuild b/dev-gap/cohomolo/cohomolo-1.6.11.ebuild
new file mode 100644
index 000000000000..7756fd073fb0
--- /dev/null
+++ b/dev-gap/cohomolo/cohomolo-1.6.11.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="Cohomology groups of finite groups on finite modules"
+SLOT="0"
+SRC_URI="https://github.com/gap-packages/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64"
+
+DEPEND="sci-mathematics/gap"
+
+GAP_PKG_HTML_DOCDIR="htm"
+GAP_PKG_EXTRA_INSTALL=( testdata standalone )
+
+gap-pkg_enable_tests
+
+src_install() {
+ # Remove standalone/progs.d so that it is not installed below. It
+ # contains the source code for the executable that we built.
+ rm -r standalone/progs.d || die
+ gap-pkg_src_install
+}