summaryrefslogtreecommitdiff
path: root/dev-gap/datastructures/datastructures-0.3.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-21 05:40:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-21 05:40:28 +0000
commitb08574f4102ea8282627f075758d981eb4ba6c56 (patch)
treee9089d8d349367b6fec26823430ba5754a23e558 /dev-gap/datastructures/datastructures-0.3.0-r1.ebuild
parent3fe8d2707d7ce24cce8f5d7eaa16b0b68cbaa2a4 (diff)
gentoo auto-resync : 21:02:2024 - 05:40:28
Diffstat (limited to 'dev-gap/datastructures/datastructures-0.3.0-r1.ebuild')
-rw-r--r--dev-gap/datastructures/datastructures-0.3.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-gap/datastructures/datastructures-0.3.0-r1.ebuild b/dev-gap/datastructures/datastructures-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..27f739021419
--- /dev/null
+++ b/dev-gap/datastructures/datastructures-0.3.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic gap-pkg
+
+DESCRIPTION="Collection of standard data structures for GAP"
+SLOT="0"
+SRC_URI="https://github.com/gap-packages/datastructures/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64"
+
+DEPEND="sci-mathematics/gap:="
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES.md README.md )
+
+gap-pkg_enable_tests
+
+src_compile() {
+ # https://github.com/gap-packages/datastructures/issues/151
+ append-cflags -Wno-error=strict-prototypes
+ gap-pkg_src_compile
+}