summaryrefslogtreecommitdiff
path: root/dev-go/coveraggregator/coveraggregator-0_pre20170216-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-go/coveraggregator/coveraggregator-0_pre20170216-r1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-go/coveraggregator/coveraggregator-0_pre20170216-r1.ebuild')
-rw-r--r--dev-go/coveraggregator/coveraggregator-0_pre20170216-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-go/coveraggregator/coveraggregator-0_pre20170216-r1.ebuild b/dev-go/coveraggregator/coveraggregator-0_pre20170216-r1.ebuild
new file mode 100644
index 000000000000..24fd828f5fec
--- /dev/null
+++ b/dev-go/coveraggregator/coveraggregator-0_pre20170216-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_VENDOR=(
+ "golang.org/x/tools a911d9008d1f732040244007778232b02ebb2b84 github.com/golang/tools"
+)
+
+inherit golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+EGO_PN=github.com/chouquette/${PN}
+HOMEPAGE="https://github.com/chouquette/coveraggregator"
+EGIT_COMMIT="af12d4d73479a1b49a16bbed8e5c182999dd62be"
+SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz
+ ${EGO_VENDOR_URI}"
+DESCRIPTION="Cover profile aggregator for golang"
+LICENSE="WTFPL-2 BSD"
+RESTRICT="test"
+SLOT="0"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #681202
+ GOPATH="${WORKDIR}/${P}" go build -v -work -x ${EGO_BUILD_FLAGS} -o ${PN} "${EGO_PN}" || die
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README.md
+}