summaryrefslogtreecommitdiff
path: root/dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild')
-rw-r--r--dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild b/dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild
new file mode 100644
index 000000000000..e7e6715fb5ba
--- /dev/null
+++ b/dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+EGO_SRC=github.com/eapache/queue
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Fast golang queue using ring-buffer"
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND=""
+RDEPEND=""