summaryrefslogtreecommitdiff
path: root/dev-go/go-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-go/go-text
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-go/go-text')
-rw-r--r--dev-go/go-text/Manifest4
-rw-r--r--dev-go/go-text/go-text-0.3.0.ebuild47
-rw-r--r--dev-go/go-text/go-text-9999.ebuild49
-rw-r--r--dev-go/go-text/metadata.xml10
4 files changed, 0 insertions, 110 deletions
diff --git a/dev-go/go-text/Manifest b/dev-go/go-text/Manifest
deleted file mode 100644
index 90019dbbddc9..000000000000
--- a/dev-go/go-text/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST go-text-0.3.0.tar.gz 6102619 BLAKE2B c92e68014a8c157d76741c02acd708771d66bd3dda5b19285f5aa3e073e0fe3fccb9054744d35ea62b681ae4421bb7489238d6868f9314fb26f88e002287abe8 SHA512 bd60dfaa7d9dbfca171a3ba40b51f5663c01257cf3b12b618d35689a97ab2212d316d5716ff09681bf40b099f7e20a0e0df8cfc065699cb6a07ad1dc2e2bc189
-EBUILD go-text-0.3.0.ebuild 1242 BLAKE2B 9678e15313b324cd5fa782d2fe7820f26d8361c20c976147882701ee45a5ab1f0f1b7510e0668b82566d3fa2c4e049d139450f06b9f90aa96c4f95280af683eb SHA512 c10154a2386a6e545a82353d7af7ea73c684e5edb94eef7f9d171d4a9f8682a0af3ef496b45dbe8284f46d36ec03080c12fc0f92a80a5c50f47241240d5f093e
-EBUILD go-text-9999.ebuild 1338 BLAKE2B 67626c28624d71879efde6859c3cd9fd02fc479e37be639a65e30ca1c0453b6f85d92d4f206e5c9babcb446ac9d93ea20ed94522d61c7f0649c7046c6ff1e6d8 SHA512 5211e039e05265c8a0d1f81b668977b5c50e8f03bb9f543c1a2ebc6f3892a0b5e2f25a5edd8ac6d4c6c343ecaa7cf482517a6ed3254fb6cbca3eaaf13164532f
-MISC metadata.xml 303 BLAKE2B 4f71d760d0181c5488da4dbaeee385634c24498abf7e9f7445bd64906e07372a7950d01b148dba050209ca90fbfb8e56420ca3abcb6a9b3878dcd9c127842b78 SHA512 97fedf2282367a08a98dcee8bd9cc987d9ec170f16d2c3bd72218063319bb9fe58cfa7328ec8fb375c1bb90b607fb3228d69cfad21c6082c08926a2c2a656969
diff --git a/dev-go/go-text/go-text-0.3.0.ebuild b/dev-go/go-text/go-text-0.3.0.ebuild
deleted file mode 100644
index c590eadea63f..000000000000
--- a/dev-go/go-text/go-text-0.3.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGO_PN=golang.org/x/text/...
-
-if [[ ${PV} = *9999* ]]; then
- inherit golang-vcs
-else
- KEYWORDS="~amd64 ~arm ~x86"
- EGIT_COMMIT="v${PV}"
- SRC_URI="https://github.com/golang/text/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- inherit golang-vcs-snapshot
-fi
-inherit golang-build
-
-DESCRIPTION="Go text processing support"
-HOMEPAGE="https://godoc.org/golang.org/x/text"
-LICENSE="BSD"
-SLOT="0/${PVR}"
-IUSE=""
-DEPEND=">=dev-go/go-tools-0_pre20180817"
-RDEPEND=""
-
-src_compile() {
- export -n GOCACHE XDG_CACHE_HOME #680946
- # Create an isolated golibdir in order to avoid an
- # "use of internal package not allowed" error when
- # and older version is installed.
- mkdir -p "${T}/golibdir/src/golang.org/x" || die
- ln -s "$(get_golibdir_gopath)/src/golang.org/x/tools" "${T}/golibdir/src/golang.org/x/tools" || die
- GOPATH="${S}:${T}/golibdir" \
- go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
-}
-
-src_install() {
- golang_install_pkgs
- exeopts -m0755 -p # preserve timestamps for bug 551486
- exeinto "$(go env GOROOT)/bin"
- doexe bin/*
-}
-
-src_test() {
- GOPATH="${S}:${T}/golibdir" \
- go test -v -work -x "${EGO_PN}" || die
-}
diff --git a/dev-go/go-text/go-text-9999.ebuild b/dev-go/go-text/go-text-9999.ebuild
deleted file mode 100644
index 0740869fb574..000000000000
--- a/dev-go/go-text/go-text-9999.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGO_SRC=golang.org/x/text
-EGO_PN=${EGO_SRC}/...
-
-if [[ ${PV} = *9999* ]]; then
- inherit golang-vcs
-else
- KEYWORDS="~amd64 ~arm ~x86"
- EGIT_COMMIT="v${PV}"
- SRC_URI="https://github.com/golang/text/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- inherit golang-vcs-snapshot
-fi
-inherit golang-build
-
-DESCRIPTION="Go text processing support"
-HOMEPAGE="https://godoc.org/golang.org/x/text"
-LICENSE="BSD"
-SLOT="0/${PVR}"
-IUSE=""
-DEPEND=">=dev-go/go-tools-0_pre20180817"
-RDEPEND=""
-
-src_compile() {
- export -n GOCACHE XDG_CACHE_HOME #680946
- # Create an isolated golibdir in order to avoid an
- # "use of internal package not allowed" error when
- # and older version is installed.
- mkdir -p "${T}/golibdir/src/golang.org/x" || die
- ln -s "$(get_golibdir_gopath)/src/golang.org/x/tools" "${T}/golibdir/src/golang.org/x/tools" || die
- GOPATH="${S}:${T}/golibdir" GOBIN="${S}/bin" \
- go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
-}
-
-src_install() {
- rm -rf "${S}/src/${EGO_SRC}/.git"* || die
- golang_install_pkgs
- exeopts -m0755 -p # preserve timestamps for bug 551486
- exeinto "$(go env GOROOT)/bin"
- doexe bin/*
-}
-
-src_test() {
- GOPATH="${S}:${T}/golibdir" GOBIN="${S}/bin" \
- go test -v -work -x "${EGO_PN}" || die
-}
diff --git a/dev-go/go-text/metadata.xml b/dev-go/go-text/metadata.xml
deleted file mode 100644
index 67636dcbe6a6..000000000000
--- a/dev-go/go-text/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>zmedico@gentoo.org</email>
- </maintainer>
- <upstream>
- <remote-id type="github">golang/text</remote-id>
- </upstream>
-</pkgmetadata>