summaryrefslogtreecommitdiff
path: root/dev-go/qr/qr-0_p20161121.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /dev-go/qr/qr-0_p20161121.ebuild
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'dev-go/qr/qr-0_p20161121.ebuild')
-rw-r--r--dev-go/qr/qr-0_p20161121.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-go/qr/qr-0_p20161121.ebuild b/dev-go/qr/qr-0_p20161121.ebuild
new file mode 100644
index 000000000000..6b53bae69d74
--- /dev/null
+++ b/dev-go/qr/qr-0_p20161121.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=rsc.io/qr
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT=48b2ede4844e13f1a2b7ce4d2529c9af7e359fc5
+ SRC_URI="https://github.com/rsc/qr/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Basic QR code library for Go"
+HOMEPAGE="https://github.com/rsc/qr"
+LICENSE="MIT"
+SLOT="0/${PVR}"
+RDEPEND=""
+
+src_install() {
+ golang-build_src_install
+
+ pushd "src/${EGO_PN}" >/dev/null || die
+ einstalldocs
+ popd >/dev/null || die
+}