summaryrefslogtreecommitdiff
path: root/dev-haskell/ac-ppm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/ac-ppm
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/ac-ppm')
-rw-r--r--dev-haskell/ac-ppm/Manifest3
-rw-r--r--dev-haskell/ac-ppm/ac-ppm-1.1.1.ebuild29
-rw-r--r--dev-haskell/ac-ppm/metadata.xml20
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/ac-ppm/Manifest b/dev-haskell/ac-ppm/Manifest
new file mode 100644
index 000000000000..9186485bb61d
--- /dev/null
+++ b/dev-haskell/ac-ppm/Manifest
@@ -0,0 +1,3 @@
+DIST AC-PPM-1.1.1.tar.gz 2958 BLAKE2B c2d5c96eebde31a45d8bd3c956687d01fc0c56906b841816bfcc80912831324fde0ccbb67f7aff99fc3efe4797fafcec554cd2599806168c9ea8c975d6f1eb0f SHA512 c296cb02fa9d70ca1f75bfdda8e307f66c800ac0e7b110bdd4af685c6acc506f3310456519d2445f850263baa22aa317266c68166bfcb551d297296d8c4de5ef
+EBUILD ac-ppm-1.1.1.ebuild 617 BLAKE2B 0d6db68d4a45704818dabfc1681889ed653f9c6dfff3f4b7f013a28172d858d07966cbf731a2fae98c9618e8137d09b4267e65e27f44c7a42502f5ef41cebdcc SHA512 adf3723ef10f9a920bfe43e72df19db72768be5efbaec264942b06f0307e245204afff2391aa2e47058f97c2b98b0a63e19e2b860e7bfe01575341119da76a37
+MISC metadata.xml 853 BLAKE2B 9e8a3c9d7ef69ba49739ae4e0befd08b0746eae2413064381c08b23a987e72cbc3f39ff44f1e1901675da0a868d7c41db25c2cd79aa8510ac2da2087558934eb SHA512 cc3e811eedb17c5d16bc84fcb4674fa2d21de42f8b6adec9c92a529664c44b6801a60b994bdb74cfb3ee21afaa167bf7549c8dab010004399e87c356e5ccc9d0
diff --git a/dev-haskell/ac-ppm/ac-ppm-1.1.1.ebuild b/dev-haskell/ac-ppm/ac-ppm-1.1.1.ebuild
new file mode 100644
index 000000000000..d04dbbbd7396
--- /dev/null
+++ b/dev-haskell/ac-ppm/ac-ppm-1.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="AC-PPM"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Trivial package for writing PPM images"
+HOMEPAGE="http://hackage.haskell.org/package/AC-PPM"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/ac-ppm/metadata.xml b/dev-haskell/ac-ppm/metadata.xml
new file mode 100644
index 000000000000..435999615a27
--- /dev/null
+++ b/dev-haskell/ac-ppm/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package is written in 100% Haskell and enables you to
+ write PPM (\&quot;Portable Pixel Map\&quot;) images in human-readable
+ text format as well as the more efficient binary format.
+ It uses the ByteString library for maximum efficiency.
+ For those that don&#39;t know, PPM is an image file format
+ which is trivially simple, but therefore horribly inefficient.
+ None the less, many programs can read PPM files, so this
+ package represents an easy way to write Haskell code that
+ generates images, without having to depend on any external
+ C code.
+ </longdescription>
+</pkgmetadata>