summaryrefslogtreecommitdiff
path: root/dev-haskell/aeson-diff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/aeson-diff
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/aeson-diff')
-rw-r--r--dev-haskell/aeson-diff/Manifest3
-rw-r--r--dev-haskell/aeson-diff/aeson-diff-1.1.0.8.ebuild48
-rw-r--r--dev-haskell/aeson-diff/metadata.xml15
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-haskell/aeson-diff/Manifest b/dev-haskell/aeson-diff/Manifest
new file mode 100644
index 000000000000..5e63526a1e5c
--- /dev/null
+++ b/dev-haskell/aeson-diff/Manifest
@@ -0,0 +1,3 @@
+DIST aeson-diff-1.1.0.8.tar.gz 16521 BLAKE2B fb72ea03dc4b35791f151f22c4fab3f9cafecd604c520137c79af5e4c71772399516d0120bd01e2335fbf7747525babedf5603e5e8d3ba244a9907c81c9f1ea8 SHA512 5a5f703dec592c0cfd825eb1899006350649c52bf810ff1aaaf4134ebfbc11f5fbe9e7f158a8c3a21dbef4902b1f9e94148bc116e27418b2b786f6d31c7561fb
+EBUILD aeson-diff-1.1.0.8.ebuild 1228 BLAKE2B 1a600f0846782dca0e39d857924ca263d2a7f15e061ca1b8aaa9f492a4adee06f8662bad77199f5a4d10eaee208857be915ec1c66effec3c98b80ae5c746b44f SHA512 7e410a2f69a139d87a4f43694e5feb069ff58c53463f0a680a81d76b8ed25d77e3ebff4eb210360a80aa37f6ba581f26bffb245ab72ca587586a5b959a219afe
+MISC metadata.xml 500 BLAKE2B 469c9336ee00e6fb94f366be1b5d1cc261a190b6359cfd4dd213045b9ce1b2f98e3f18dcb239cff1018698713e5fb70691cf15aaa4926dbef2084bfffc98b535 SHA512 8f041437e868502b07c4dbfb7c958c5a7f7acbb7ab8a9bb6ab271bbbea995f59f6ab181d3cf1352a9ef5b40fe5a00b5560b1be73384dace26459c791c19388e4
diff --git a/dev-haskell/aeson-diff/aeson-diff-1.1.0.8.ebuild b/dev-haskell/aeson-diff/aeson-diff-1.1.0.8.ebuild
new file mode 100644
index 000000000000..d44881aa49be
--- /dev/null
+++ b/dev-haskell/aeson-diff/aeson-diff-1.1.0.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Extract and apply patches to JSON documents"
+HOMEPAGE="https://github.com/thsutton/aeson-diff"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Ambiguous module name ‘Data.Vector’: found in multiple packages: AC-Vector-Fancy-2.4.0 vector-0.12.0.2
+RESTRICT=test
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/edit-distance-vector:=[profile?]
+ dev-haskell/hashable:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/optparse-applicative:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+ test? ( >=dev-haskell/doctest-0.9
+ dev-haskell/glob
+ dev-haskell/hlint
+ dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >=4.9 && <4.14' 'base >=4.9'
+}
diff --git a/dev-haskell/aeson-diff/metadata.xml b/dev-haskell/aeson-diff/metadata.xml
new file mode 100644
index 000000000000..e984d020b504
--- /dev/null
+++ b/dev-haskell/aeson-diff/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+
+ This is a small library for working with changes to JSON documents. It
+ includes a library and two command-line executables in the style of the
+ diff(1) and patch(1) commands available on many systems.
+
+ </longdescription>
+</pkgmetadata>