summaryrefslogtreecommitdiff
path: root/dev-haskell/ascii-progress/ascii-progress-0.3.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /dev-haskell/ascii-progress/ascii-progress-0.3.3.0.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'dev-haskell/ascii-progress/ascii-progress-0.3.3.0.ebuild')
-rw-r--r--dev-haskell/ascii-progress/ascii-progress-0.3.3.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/ascii-progress/ascii-progress-0.3.3.0.ebuild b/dev-haskell/ascii-progress/ascii-progress-0.3.3.0.ebuild
new file mode 100644
index 000000000000..e5cc5e951f48
--- /dev/null
+++ b/dev-haskell/ascii-progress/ascii-progress-0.3.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A simple progress bar for the console"
+HOMEPAGE="https://github.com/yamadapc/haskell-ascii-progress"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-haskell/async-2.0.1.5:=[profile?]
+ >=dev-haskell/concurrent-output-1.7:=[profile?]
+ >=dev-haskell/data-default-0.5.3:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+ examples? ( >=dev-haskell/conduit-1.2:=[profile?]
+ dev-haskell/http:=[profile?]
+ >=dev-haskell/http-conduit-2.1:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-haskell/transformers-0.3:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/hspec-2.1 <dev-haskell/hspec-3
+ >=dev-haskell/quickcheck-2.6 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples examples)
+}