summaryrefslogtreecommitdiff
path: root/dev-haskell/async
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/async
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/async')
-rw-r--r--dev-haskell/async/Manifest7
-rw-r--r--dev-haskell/async/async-2.0.1.4.ebuild33
-rw-r--r--dev-haskell/async/async-2.0.2.ebuild28
-rw-r--r--dev-haskell/async/async-2.1.1.ebuild28
-rw-r--r--dev-haskell/async/metadata.xml53
5 files changed, 149 insertions, 0 deletions
diff --git a/dev-haskell/async/Manifest b/dev-haskell/async/Manifest
new file mode 100644
index 000000000000..98cf4349d1be
--- /dev/null
+++ b/dev-haskell/async/Manifest
@@ -0,0 +1,7 @@
+DIST async-2.0.1.4.tar.gz 8349 BLAKE2B 3323c08beddd482a3d0442fd64afebabb01cd8307dae2650ee27687ca247c73eaf0ce45f953180ecf4f706705041933cd0387699ca1592d72b63761932b47790 SHA512 8b170644ce92f9788e22771239542e46ee14b9898404744f6a97b955ef22ae4b3fa280ea759f228cb22f2083b5ee007f39c61063f82e5cce8f6bf1c6df789a71
+DIST async-2.0.2.tar.gz 8565 BLAKE2B 8bda599c7a5bd30b67d73de87f136eae3535619e3eb274b928f6536cc2c4f6f03d73ff31e619f8681449fdf501aa08b83c2324e1121ffcfeaa69d732df7675d7 SHA512 beac3452aca98f9c41fb86b1b9e105a324df5a05e10c7d616927bb94888d6d2ed5385e0ec901fdfa050a43e991f5089757d3941ce97db98c148a159893bddc1e
+DIST async-2.1.1.tar.gz 10565 BLAKE2B a379efe6df6c58d1962d820b0f1370c87af487b61f7c3ed32fb22398d77be8265a9577d44793624fd8b0d41c930c2f94106511d816df9600e7b7a17b897641bc SHA512 85a878389f019df0038f7b0ea82e8619f30eed97cc5c53438dbcaef128c08cdf5658afa203605434a2e1eb885fc28515a30c83341cb1b77331362205d521972b
+EBUILD async-2.0.1.4.ebuild 832 BLAKE2B f9960f60231759f3935221703e7aed56148e2273df5d1ef61b06cf41bd9364ba1aa2e4ac7812158ebf71f18a3983c4daa0159aa6f1b00c118c452b956f42a370 SHA512 3582d92b5d21906c92cb6ca7b642f4edf86391f4dc301312230f526f4bf076ad109d18faacf473a523394d23a91b2cfd0fbb657cfbecde7956e8641b4b6fb1d4
+EBUILD async-2.0.2.ebuild 755 BLAKE2B f8f75b6b534ee323a579fb2a37ae8e294390a45c5222f899b943675983c9da32a65d56f0f3893388d26a2cf7e3f1ca4d77aa36b73fc3cfa660e00a4737c23eca SHA512 6d2fceed548b4673b799b04f3c8448bd8706520a9f7f60af11f1c0613e3d0ef62a3e176a3b55ab511025e41d3c16ee54cfa5656d71ca588e792a417498512648
+EBUILD async-2.1.1.ebuild 756 BLAKE2B 8e75874e7b75aa157d176edf261a79705747130d60908ced3269d2e95f98d5ec45fa8570bb09b1cd8580140e5f6dd76cf253b2b8a33bfc2e89d7361260173f61 SHA512 e9a8e214d78534f3b56fdf6b72f34240b60acfe779a1e34160f0523bd00be1bb526b5eb093f8acda2a36bb2ea162e87676434c22e20474dce8d8a387e9e500b9
+MISC metadata.xml 1591 BLAKE2B e513dd2e93240046dadb6412fa548d7a7390700a80d241a4fc00a8204220541fec695e82fdd64a122dcf923f6ec91c8ba67c627c6997386cc09b24956364d3f3 SHA512 9fb7bd1b705dc30c1e8bfeedf6cb4f3ce0391b60dc0eb362536615e7e693cfff0917fa74c1fc725811db1017d186782994b3aeb106059fca5852c1232f48080e
diff --git a/dev-haskell/async/async-2.0.1.4.ebuild b/dev-haskell/async/async-2.0.1.4.ebuild
new file mode 100644
index 000000000000..8492c7691579
--- /dev/null
+++ b/dev-haskell/async/async-2.0.1.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Run IO operations asynchronously and wait for their results"
+HOMEPAGE="https://github.com/simonmar/async"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/stm-2.2:=[profile?]
+ <dev-haskell/stm-2.5:=[profile?]
+ >=dev-lang/ghc-7.0.1:="
+DEPEND="${RDEPEND}
+ test? ( dev-haskell/hunit
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ )
+ >=dev-haskell/cabal-1.8"
+
+src_prepare() {
+ cabal_chdeps \
+ 'base >= 4.3 && < 4.7' 'base >= 4.3'
+}
diff --git a/dev-haskell/async/async-2.0.2.ebuild b/dev-haskell/async/async-2.0.2.ebuild
new file mode 100644
index 000000000000..411a79cea032
--- /dev/null
+++ b/dev-haskell/async/async-2.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Run IO operations asynchronously and wait for their results"
+HOMEPAGE="https://github.com/simonmar/async"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/stm-2.2:=[profile?] <dev-haskell/stm-2.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit )
+"
diff --git a/dev-haskell/async/async-2.1.1.ebuild b/dev-haskell/async/async-2.1.1.ebuild
new file mode 100644
index 000000000000..3827b4ce1cb8
--- /dev/null
+++ b/dev-haskell/async/async-2.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Run IO operations asynchronously and wait for their results"
+HOMEPAGE="https://github.com/simonmar/async"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/stm-2.2:=[profile?] <dev-haskell/stm-2.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/hunit
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit )
+"
diff --git a/dev-haskell/async/metadata.xml b/dev-haskell/async/metadata.xml
new file mode 100644
index 000000000000..85a5a5773f03
--- /dev/null
+++ b/dev-haskell/async/metadata.xml
@@ -0,0 +1,53 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This package provides a higher-level interface over
+ threads, in which an @Async a@ is a concurrent
+ thread that will eventually deliver a value of
+ type @a@. The package provides ways to create
+ @Async@ computations, wait for their results, and
+ cancel them.
+
+ Using @Async@ is safer than using threads in two
+ ways:
+
+ * When waiting for a thread to return a result,
+ if the thread dies with an exception then the
+ caller must either re-throw the exception
+ ('wait') or handle it ('waitCatch'); the
+ exception cannot be ignored.
+
+ * The API makes it possible to build a tree of
+ threads that are automatically killed when
+ their parent dies (see 'withAsync').
+
+ Changes in 2.0.1.3:
+
+ * Bump @base@ dependency to allow 4.6
+
+ Changes in 2.0.1.2:
+
+ * Bump @stm@ dependency to 2.4
+
+ Changes in 2.0.1.1:
+
+ * Safe Haskell support: @Control.Concurrent.Async@ is now @Trustworthy@
+
+ Changes in 2.0.1.0:
+
+ * Added a @Functor@ instance for @Async@
+
+ * Added @asyncBound@, @asyncOn@, @asyncWithUnmask@, @asyncOnWithUnmask@, @withAsyncBound@, @withAsyncOn@, @withAsyncWithUnmask@, @withAsyncOnWithUnmask@.
+
+ * Added @mapConcurrently@
+
+ * Added @Concurrently@ (with @Applicative@ and @Alternative@ instances)
+ </longdescription>
+ <upstream>
+ <remote-id type="github">simonmar/async</remote-id>
+ </upstream>
+</pkgmetadata>