summaryrefslogtreecommitdiff
path: root/dev-haskell/aws
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/aws
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/aws')
-rw-r--r--dev-haskell/aws/Manifest4
-rw-r--r--dev-haskell/aws/aws-0.24.ebuild71
-rw-r--r--dev-haskell/aws/metadata.xml4
3 files changed, 75 insertions, 4 deletions
diff --git a/dev-haskell/aws/Manifest b/dev-haskell/aws/Manifest
index 9554e922427c..073a8362fadd 100644
--- a/dev-haskell/aws/Manifest
+++ b/dev-haskell/aws/Manifest
@@ -1,5 +1,7 @@
AUX aws-0.22-aeson-2.patch 7603 BLAKE2B 6c3247b7b9e580fa462e11d41bad7b42131a4212a9a8c678f74a337cc15099694e565d6019e8b90f28fc9568827dcac97c99fe25569e7efc4ae5ddece42d079c SHA512 b439e8178c5a70278e23b9dbc7eb74c26358a81bdba27e8b12584439c2e59c52c0c662575f70c56e150f487d6d4094739a1e7816eb89583a893d15b37aa3892a
DIST aws-0.22-rev3.cabal 15515 BLAKE2B 7936d1ba22ef5d60baf8804d5d77b5202f6fcef31b63cba9c06ffe5f66aae8d584c3877887e408033efe36bc9cf04c738c545ca61e9eceeaee61bb168ac1e062 SHA512 a6a1d639cedf6929f60cf4b4187fbefb72f7024cbdaa3c3d383acc933be1f03b139c4b58a34afaf7ecdc355ee507f4411e9953f98127850d4978a6ba859f4e8e
DIST aws-0.22.tar.gz 106122 BLAKE2B b4ff46e2742d53323c80952c303a4605d13600fd60085a2e0501af2fc0a74f0c2769c6bf0692710bbfd972c474b9cab26fd97e9126fdcfb3eaff90afbab1d9ae SHA512 e7ff376c47a7ca7a65c8f10f19e591d4a4b4d2cfa333b4727f88f0b170d7acb0aff402617f2d617c522fe5d16ce92b249a23f1fb0a8bfe5bbefaef2931b786bd
+DIST aws-0.24.tar.gz 106782 BLAKE2B 3e9feb13f3e21577c0bf9969865f3475c40e466a2377cd659171166e6b9727b6c501f4a31b7de4720fc6a0ec4d4b266732e3c2eb34d0b4bb38527a6babfebe4a SHA512 d453ea185a47b0fb93d2e8849ea81e1b0bae081aa81d280f94618d8fb357b6e4b71a43a6c8df0e4ba2b64390346daf50672ed9f9849cc6737a5ae58b5ac52af8
EBUILD aws-0.22-r5.ebuild 2965 BLAKE2B c3d64545a93a634b45256cc459c222fccf50b3ff24d50408845e5c8d86e66c636774731831d0b36261d794a2b1a9b85678abedc29235a90d12c57f6624ecb397 SHA512 f35b0cb1710fc24de12129a174deaa38f45fdbfb82b45285b652aae8ffa351889d5bff3bc1d7aa74a8cd1a128394fb874c50e40dccdcd2178ce4a74d8d9dca32
-MISC metadata.xml 580 BLAKE2B 2f6f53f53684dd447ad3c69e408afb8740a8ff0d565c75fa4c5aa55e271f73d79eb42969a7c48320b80096ea53daacaaf5fb22e52de91e388ec96b8b12129b85 SHA512 f3f8d31ba04946e95357b929e5aa611cfe8b58ee484837767eceb2aab10fd07b20e7c7cb2f6fa60f8a409980ef5fdc5294aeaa9656e61365ed2674c9b63b0391
+EBUILD aws-0.24.ebuild 3223 BLAKE2B c68a4a47f073bb6b415c24aab9c385ab01bada9bca26b1fdc0ee21e396cb1c53d6fb030fa8c3ee0d4503ca885e79651ea7ea3859fac87c943b6f22495607f415 SHA512 9d9a9f3b40bb5af473bc4a0dc082bc15eb8d8ffa667b476733356f45e6337e99cd4e3237fefd6db8e4fe86c0f683d4350ccd8161e2c6ecac28a35620486d4502
+MISC metadata.xml 371 BLAKE2B 54503e03d5cab2ad2123f363302f9bb9f4aebdb0292bb21d1686fd70803b146bc042e30df22aa396e7dc04257ec3c00956b7d15f5670613e78bd42aec0c9812e SHA512 57b66812b6a0adfb00c43273dfd4ba240b418551a79182e023fff4a27a1da2887bdcbb6d5064a12065cf384b2d8a1acb63c852336d4c85990011dbe72cbe8058
diff --git a/dev-haskell/aws/aws-0.24.ebuild b/dev-haskell/aws/aws-0.24.ebuild
new file mode 100644
index 000000000000..acd4e2c2fe01
--- /dev/null
+++ b/dev-haskell/aws/aws-0.24.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+#hackport: flags: +networkbsd
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Amazon Web Services (AWS) for Haskell"
+HOMEPAGE="https://github.com/aristidb/aws"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="examples"
+
+RESTRICT=test # requires aws account
+
+RDEPEND=">=dev-haskell/aeson-2.0.0.0:=[profile?]
+ >=dev-haskell/attoparsec-0.11:=[profile?] <dev-haskell/attoparsec-0.15:=[profile?]
+ >=dev-haskell/base16-bytestring-0.1:=[profile?] <dev-haskell/base16-bytestring-1.1:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.3:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/byteable-0.1:=[profile?] <dev-haskell/byteable-0.2:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/cereal-0.3:=[profile?] <dev-haskell/cereal-0.6:=[profile?]
+ >=dev-haskell/conduit-1.3:=[profile?] <dev-haskell/conduit-1.4:=[profile?]
+ >=dev-haskell/conduit-extra-1.3:=[profile?] <dev-haskell/conduit-extra-1.4:=[profile?]
+ >=dev-haskell/cryptonite-0.11:=[profile?]
+ >=dev-haskell/data-default-0.5.3:=[profile?] <dev-haskell/data-default-0.8:=[profile?]
+ >=dev-haskell/http-client-tls-0.3:=[profile?] <dev-haskell/http-client-tls-0.4:=[profile?]
+ >=dev-haskell/http-conduit-2.3:=[profile?] <dev-haskell/http-conduit-2.4:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?] <dev-haskell/http-types-1.0:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
+ dev-haskell/memory:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?]
+ >=dev-haskell/network-3:=[profile?] <dev-haskell/network-4:=[profile?]
+ >=dev-haskell/network-bsd-2.8:=[profile?] <dev-haskell/network-bsd-2.9:=[profile?]
+ >=dev-haskell/old-locale-1:=[profile?] <dev-haskell/old-locale-2:=[profile?]
+ >=dev-haskell/resourcet-1.2:=[profile?] <dev-haskell/resourcet-1.3:=[profile?]
+ >=dev-haskell/safe-0.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?]
+ >=dev-haskell/xml-conduit-1.8:=[profile?] <dev-haskell/xml-conduit-2.0:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+ examples? ( >=dev-haskell/errors-2.0:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? ( >=dev-haskell/http-client-0.3 <dev-haskell/http-client-0.8
+ >=dev-haskell/lifted-base-0.2
+ >=dev-haskell/quickcheck-2.7
+ >=dev-haskell/quickcheck-instances-0.3
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-hunit-0.8
+ >=dev-haskell/tasty-quickcheck-0.8
+ >=dev-haskell/transformers-base-0.4
+ !examples? ( >=dev-haskell/errors-2.0 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples examples) \
+ --flag=networkbsd
+}
diff --git a/dev-haskell/aws/metadata.xml b/dev-haskell/aws/metadata.xml
index cc08513f82e8..6fe81a3157ca 100644
--- a/dev-haskell/aws/metadata.xml
+++ b/dev-haskell/aws/metadata.xml
@@ -5,10 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Bindings for Amazon Web Services (AWS), with the aim of supporting all AWS services. To see a high level overview of the library, see the README at &lt;https://github.com/aristidb/aws/blob/master/README.org&gt;.
- </longdescription>
<upstream>
+ <remote-id type="hackage">aws</remote-id>
<remote-id type="github">aristidb/aws</remote-id>
</upstream>
</pkgmetadata>