summaryrefslogtreecommitdiff
path: root/dev-haskell/binary-orphans
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/binary-orphans
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/binary-orphans')
-rw-r--r--dev-haskell/binary-orphans/Manifest3
-rw-r--r--dev-haskell/binary-orphans/binary-orphans-0.1.6.0-r1.ebuild48
-rw-r--r--dev-haskell/binary-orphans/metadata.xml11
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-haskell/binary-orphans/Manifest b/dev-haskell/binary-orphans/Manifest
new file mode 100644
index 000000000000..08a7aa69ae88
--- /dev/null
+++ b/dev-haskell/binary-orphans/Manifest
@@ -0,0 +1,3 @@
+DIST binary-orphans-0.1.6.0.tar.gz 5320 BLAKE2B 3e8393e64ee737316457ee7f36f740404b0f4adaac2134701c935608ac90714473148d8844c167262a058de607f86a2d8d0b2527e6cb07f50f054b77629df97d SHA512 646410b79d92a20ef7b6d6583fca38da672e7fe072d2d5a7a9d50bacd1fb3da20efd9ab42e74029279dcd5a2c4b80218b860ae8e45bef348a692b23bcc8ea351
+EBUILD binary-orphans-0.1.6.0-r1.ebuild 2046 BLAKE2B f8eb9a530204f5c0c4e0ad64f9477392137a6cba5540868b3d858575c3520e0afec8c8725d252859a7f8546804b79c4e9cfe8862e02def935aab62f1bf9315aa SHA512 0626c811c11ae897901d43d06729cd7a03b849328c2a5b7762abebde6ff173062ca746e09f227455be28dfd80026629cea238b2c60634e5b569679a16f246529
+MISC metadata.xml 368 BLAKE2B 980ea993294e02c8c2fd09b62f27b7885ff21e6458308003ef61078715b7f82fa784a10e99ca0b89e290ae84d3ce1e8bc97ce6fcb318818c3e6c45657594aaec SHA512 e5dc324c3ec28d21fa959b06947784d263dff0b6a7094ea1a19ef477cf235aa5b2655d72ce3c6ea87fa9e2f429f2e9a80858ca8fc8d61b5e263cb9bb13f7180a
diff --git a/dev-haskell/binary-orphans/binary-orphans-0.1.6.0-r1.ebuild b/dev-haskell/binary-orphans/binary-orphans-0.1.6.0-r1.ebuild
new file mode 100644
index 000000000000..d47e578a5ab3
--- /dev/null
+++ b/dev-haskell/binary-orphans/binary-orphans-0.1.6.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Orphan instances for binary"
+HOMEPAGE="https://github.com/phadej/binary-orphans#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.7.0.6:=[profile?] <dev-haskell/aeson-1.2:=[profile?]
+ >=dev-haskell/case-insensitive-1.2.0.4:=[profile?] <dev-haskell/case-insensitive-1.2.1:=[profile?]
+ >=dev-haskell/hashable-1.2.3.3:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ >=dev-haskell/nats-1:=[profile?] <dev-haskell/nats-1.2:=[profile?]
+ >=dev-haskell/scientific-0.3.3.8:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/semigroups-0.16.2.2:=[profile?]
+ >=dev-haskell/tagged-0.7.3:=[profile?] <dev-haskell/tagged-0.8.6:=[profile?]
+ >=dev-haskell/text-1.2.0.6:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/text-binary-0.1.0:=[profile?] <dev-haskell/text-binary-0.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.5.1:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.10.12.3:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-haskell/vector-binary-instances-0.2.1.0:=[profile?] <dev-haskell/vector-binary-instances-0.3:=[profile?]
+ >=dev-haskell/void-0.7:=[profile?] <dev-haskell/void-0.8:=[profile?]
+ >=dev-lang/ghc-7.6.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/quickcheck-2.7 <dev-haskell/quickcheck-2.9.3
+ >=dev-haskell/quickcheck-instances-0.3.11 <dev-haskell/quickcheck-instances-0.3.13
+ >=dev-haskell/tasty-0.10.1.2 <dev-haskell/tasty-0.12
+ >=dev-haskell/tasty-quickcheck-0.8.3.2 <dev-haskell/tasty-quickcheck-0.9 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'semigroups >=0.16.2.2 && <0.18.3' 'semigroups >=0.16.2.2'
+}
diff --git a/dev-haskell/binary-orphans/metadata.xml b/dev-haskell/binary-orphans/metadata.xml
new file mode 100644
index 000000000000..3b512c102ba0
--- /dev/null
+++ b/dev-haskell/binary-orphans/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ `binary-orphans` defines orphan instances for types in some popular packages.
+ </longdescription>
+</pkgmetadata>