summaryrefslogtreecommitdiff
path: root/dev-haskell/bytestring-handle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-haskell/bytestring-handle
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-haskell/bytestring-handle')
-rw-r--r--dev-haskell/bytestring-handle/Manifest2
-rw-r--r--dev-haskell/bytestring-handle/bytestring-handle-0.1.0.6.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/bytestring-handle/Manifest b/dev-haskell/bytestring-handle/Manifest
index 9e7c393c6952..d7ae416f18a3 100644
--- a/dev-haskell/bytestring-handle/Manifest
+++ b/dev-haskell/bytestring-handle/Manifest
@@ -1,3 +1,5 @@
DIST bytestring-handle-0.1.0.4.tar.gz 6204 BLAKE2B bcda8d126b5e60f1f78be576ec0233f8b0afe80409afd9a796c0a86e83f3b05702eb40ed09af1ebb2d2b8b194924084a0799ca6b498acd654a18d679b1184415 SHA512 17649968ffbebf1a567059ecf3f19e8d8f6a1bb53a0b491e35b62d572cff9f949822953452ee72d193546d8779d6d71dfd82ae5cfd2d3b7564ac73df7283facb
+DIST bytestring-handle-0.1.0.6.tar.gz 6203 BLAKE2B e821b33a97983e124c679c2b9f2316151e695ebf615f739d50b5d4524804878dddb861d2abd7708ad635cd563a007e867232f81f229b368b5ca4afb90d4730cf SHA512 a585488207680a6f1ba6538cf10d03e059010d42994803f9edc6d9c1fff08e479117a6d1449f923a8d5de9884b93438e80b81c75978e5c3145310c21ba14498c
EBUILD bytestring-handle-0.1.0.4.ebuild 976 BLAKE2B 80f1339c0448450e742ac89d1fb78a7c06d7f555428d8e390884f098a1adf4f2e335cf50e9afa35eceaad900961532cb241310c430819484b40fd457fbf66fca SHA512 cfacdad6b8a93f3d0c8d76a55c6743de15cfab0a428ae91f8a1461971e8b877bb8ba65c6ab3933352b6a6f9664d4f107cddfa3b3fcf62b7f7d72999b056e34a9
+EBUILD bytestring-handle-0.1.0.6.ebuild 1020 BLAKE2B 632e3950dacd2ccfe3fc0f8b992f43ed6abd75d1f5cf02588565af04ad30fae83b9c3f7e2a55be90db1087141ff191161c8f5109ab97e726d73b5c90b9c6c88b SHA512 698c19c9861825ebad42aaf8cbbfb2822d6756b27ecb3224cc00343710275efa1132f191a2e949b19b892ddec1c77c797b33692c0ea0d3c8eb7ee5f0b86f75c6
MISC metadata.xml 316 BLAKE2B daa54860b18245646d20089598390b0fba4e618749bfdd5bd719773856b48ca0bccd48f320947293f570f251a43618282e25aa39a30a2486d52e71fae8dab186 SHA512 67707af77347270b5c525ece5a127ae66affc8ae3cb5860748950171e8d8416c294b0f1da5be25bbdba9fa75bc91878e2f04dc73bfc1d35af02f9635fcdc47f0
diff --git a/dev-haskell/bytestring-handle/bytestring-handle-0.1.0.6.ebuild b/dev-haskell/bytestring-handle/bytestring-handle-0.1.0.6.ebuild
new file mode 100644
index 000000000000..fa9840c071ac
--- /dev/null
+++ b/dev-haskell/bytestring-handle/bytestring-handle-0.1.0.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="ByteString-backed Handles"
+HOMEPAGE="http://hub.darcs.net/ganesh/bytestring-handle"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.7
+ >=dev-haskell/quickcheck-2.1.2
+ >=dev-haskell/test-framework-0.2.0 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2.0 <dev-haskell/test-framework-hunit-0.4
+ >=dev-haskell/test-framework-quickcheck2-0.2.5 <dev-haskell/test-framework-quickcheck2-0.4 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4.2 && < 4.11' 'base >= 4.2' \
+ 'QuickCheck >= 2.1.2 && < 2.11' 'QuickCheck >= 2.1.2'
+}