summaryrefslogtreecommitdiff
path: root/dev-haskell/cabal/cabal-1.24.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/cabal/cabal-1.24.2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/cabal/cabal-1.24.2.0.ebuild')
-rw-r--r--dev-haskell/cabal/cabal-1.24.2.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/cabal/cabal-1.24.2.0.ebuild b/dev-haskell/cabal/cabal-1.24.2.0.ebuild
new file mode 100644
index 000000000000..c98a9733edd2
--- /dev/null
+++ b/dev-haskell/cabal/cabal-1.24.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+#hackport: flags: -bundled-binary-generic
+
+CABAL_FEATURES="lib profile test-suite"
+CABAL_FEATURES+=" nocabaldep" # in case installed Cabal is broken
+inherit haskell-cabal
+
+MY_PN="Cabal"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A framework for packaging Haskell software"
+HOMEPAGE="http://www.haskell.org/cabal/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RESTRICT=test # circular dependencies
+
+RDEPEND=">=dev-lang/ghc-7.8.1:="
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+CABAL_CORE_LIB_GHC_PV="PM:8.0.2_rc2 PM:8.0.2"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bundled-binary-generic
+}