summaryrefslogtreecommitdiff
path: root/dev-haskell/chell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-haskell/chell
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/chell')
-rw-r--r--dev-haskell/chell/Manifest3
-rw-r--r--dev-haskell/chell/chell-0.4.0.1.ebuild35
-rw-r--r--dev-haskell/chell/metadata.xml48
3 files changed, 0 insertions, 86 deletions
diff --git a/dev-haskell/chell/Manifest b/dev-haskell/chell/Manifest
deleted file mode 100644
index 1f5e99a0c246..000000000000
--- a/dev-haskell/chell/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST chell-0.4.0.1.tar.gz 12441 BLAKE2B 450827af0cfe005b6c6c17e59229d7aceef6b4609b9c81672829d4c4818e5d9ab03752e6b44efc73fd0a614c881e0326faec881613e8f2ce68c75bcbd1e06e69 SHA512 5a11e38fdd6c4f323d077dc3adc35c9626229a49f6ed32a0202031094f2612ec3e26a28f96819366439c1ec97ddfd839050f207d03c90a749890ef2bb345b8c3
-EBUILD chell-0.4.0.1.ebuild 1069 BLAKE2B b7b382b11efccbceac8dcc1b058fe0c4340bf3fa7f75d5bd5bd643d52c1a63ed302dd008230823713bd7cecdec2cbe0605d80664bdd9b55ec2034bad29dd1783 SHA512 017e138b1d88f077f39ea34c6fbb44ad616250b2db4dd854eb23010a5b0f891694d90cc7f16ba4948f93e360b64cc04b560516f4aced486e46455cee57e06866
-MISC metadata.xml 1348 BLAKE2B 7a683e9440cbb07cc4d3546f3b8727801ed177136eb20a3df82a0ce11589e4f236bd175b68b796d447e6b9eec4a87238050d88371d8c92d8a054b01f4c71e9f7 SHA512 4c6e16171c20c2f2e21ca663a5c9b76d57e202ee1cb99317417de758b6fcefe0a7b44ea0177c20f8549ca7f48e4238d8b854a0d12548d9041c2265a4b9138ad5
diff --git a/dev-haskell/chell/chell-0.4.0.1.ebuild b/dev-haskell/chell/chell-0.4.0.1.ebuild
deleted file mode 100644
index a89b0baa6803..000000000000
--- a/dev-haskell/chell/chell-0.4.0.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.4.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="A simple and intuitive library for automated testing"
-HOMEPAGE="https://john-millikin.com/software/chell/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
-IUSE="+color-output"
-
-RDEPEND=">=dev-haskell/options-1.0:=[profile?] <dev-haskell/options-2.0:=[profile?]
- >=dev-haskell/patience-0.1:=[profile?] <dev-haskell/patience-0.2:=[profile?]
- >=dev-haskell/random-1.0:=[profile?]
- dev-haskell/text:=[profile?]
- >=dev-haskell/transformers-0.2:=[profile?]
- >=dev-lang/ghc-7.4.1:=
- color-output? ( >=dev-haskell/ansi-terminal-0.5:=[profile?] <dev-haskell/ansi-terminal-0.7:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag color-output color-output)
-}
diff --git a/dev-haskell/chell/metadata.xml b/dev-haskell/chell/metadata.xml
deleted file mode 100644
index bc57a63871b2..000000000000
--- a/dev-haskell/chell/metadata.xml
+++ /dev/null
@@ -1,48 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- Chell is a simple and intuitive library for automated testing. It natively
- supports assertion-based testing, and can use companion libraries
- such as @chell-quickcheck@ to support more complex testing strategies.
-
- An example test suite, which verifies the behavior of artithmetic operators.
-
- @
- &amp;#x7b;-\# LANGUAGE TemplateHaskell \#-&amp;#x7d;
-
- import Test.Chell
-
- tests_Math :: Suite
- tests_Math = suite \"math\"
- &amp;#x20; test_Addition
- &amp;#x20; test_Subtraction
-
- test_Addition :: Test
- test_Addition = assertions \"addition\" $ do
- &amp;#x20; $expect (equal (2 + 1) 3)
- &amp;#x20; $expect (equal (1 + 2) 3)
-
- test_Subtraction :: Test
- test_Subtraction = assertions \"subtraction\" $ do
- &amp;#x20; $expect (equal (2 - 1) 1)
- &amp;#x20; $expect (equal (1 - 2) (-1))
-
- main :: IO ()
- main = defaultMain [tests_Math]
- @
-
- @
- $ ghc --make chell-example.hs
- $ ./chell-example
- PASS: 2 tests run, 2 tests passed
- @
- </longdescription>
- <use>
- <flag name="color-output">use colors in program output</flag>
- </use>
-</pkgmetadata>