summaryrefslogtreecommitdiff
path: root/dev-haskell/cipher-aes/cipher-aes-0.2.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-haskell/cipher-aes/cipher-aes-0.2.11.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/cipher-aes/cipher-aes-0.2.11.ebuild')
-rw-r--r--dev-haskell/cipher-aes/cipher-aes-0.2.11.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-haskell/cipher-aes/cipher-aes-0.2.11.ebuild b/dev-haskell/cipher-aes/cipher-aes-0.2.11.ebuild
deleted file mode 100644
index 920726217d88..000000000000
--- a/dev-haskell/cipher-aes/cipher-aes-0.2.11.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.5.9999
-#hackport: flags: support_aesni:cpu_flags_x86_aes
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Fast AES cipher implementation with advanced mode of operations"
-HOMEPAGE="https://github.com/vincenthz/hs-cipher-aes"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="cpu_flags_x86_aes cpu_flags_x86_ssse3"
-
-RDEPEND="dev-haskell/byteable:=[profile?]
- >=dev-haskell/crypto-cipher-types-0.0.6:=[profile?] <dev-haskell/crypto-cipher-types-0.1:=[profile?]
- >=dev-haskell/securemem-0.1.2:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? ( >=dev-haskell/crypto-cipher-tests-0.0.8
- >=dev-haskell/quickcheck-2
- >=dev-haskell/test-framework-0.3.3
- >=dev-haskell/test-framework-quickcheck2-0.2.9 )
-"
-
-src_configure() {
- local want_aes="-"
-
- use cpu_flags_x86_aes && \
- use cpu_flags_x86_ssse3 && \
- want_aes=""
-
- haskell-cabal_src_configure \
- --flag=${want_aes}support_aesni
-}