summaryrefslogtreecommitdiff
path: root/dev-haskell/cipher-aes/cipher-aes-0.2.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/cipher-aes/cipher-aes-0.2.11.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/cipher-aes/cipher-aes-0.2.11.ebuild')
-rw-r--r--dev-haskell/cipher-aes/cipher-aes-0.2.11.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-haskell/cipher-aes/cipher-aes-0.2.11.ebuild b/dev-haskell/cipher-aes/cipher-aes-0.2.11.ebuild
new file mode 100644
index 000000000000..920726217d88
--- /dev/null
+++ b/dev-haskell/cipher-aes/cipher-aes-0.2.11.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+#hackport: flags: support_aesni:cpu_flags_x86_aes
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast AES cipher implementation with advanced mode of operations"
+HOMEPAGE="https://github.com/vincenthz/hs-cipher-aes"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_aes cpu_flags_x86_ssse3"
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.6:=[profile?] <dev-haskell/crypto-cipher-types-0.1:=[profile?]
+ >=dev-haskell/securemem-0.1.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/crypto-cipher-tests-0.0.8
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
+
+src_configure() {
+ local want_aes="-"
+
+ use cpu_flags_x86_aes && \
+ use cpu_flags_x86_ssse3 && \
+ want_aes=""
+
+ haskell-cabal_src_configure \
+ --flag=${want_aes}support_aesni
+}