summaryrefslogtreecommitdiff
path: root/dev-haskell/cipher-aes128
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/cipher-aes128
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/cipher-aes128')
-rw-r--r--dev-haskell/cipher-aes128/Manifest3
-rw-r--r--dev-haskell/cipher-aes128/cipher-aes128-0.7.0.5-r1.ebuild41
-rw-r--r--dev-haskell/cipher-aes128/metadata.xml15
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-haskell/cipher-aes128/Manifest b/dev-haskell/cipher-aes128/Manifest
new file mode 100644
index 000000000000..da8b16f64123
--- /dev/null
+++ b/dev-haskell/cipher-aes128/Manifest
@@ -0,0 +1,3 @@
+DIST cipher-aes128-0.7.0.5.tar.gz 26228 BLAKE2B 8ef1aa343563d7889154b5f0b96b5b457ed21afbcad4f90f82e95a080c19f50d8ad2500ef4b8caa1509ca953aba3ca1941c61656417ed527943858a9d6cfd652 SHA512 8479dec68d6fa35e8d615bcc8c6336459fa537f1962b7af87e63b0c38d544ed26e6d30e980f90bb3585513bd618e01330d3e008e77404dae8d2e27954d7a535a
+EBUILD cipher-aes128-0.7.0.5-r1.ebuild 893 BLAKE2B 0baf8e6ef4b28965af10b8740b44cab6532c16701a0dbe46ae9656a206daf6953496ab97ad1f461a5161a306a5bbde10b47b7d87de2dc65ef68256646ee56105 SHA512 6cf83ec97174cc6fcf64a87fc93259ca434d225227bc52671f2e29bf20bdbe12e45c69f5647b7e4bad5cb6db5a473af82e1bc22504fc4a06885b761c641a1010
+MISC metadata.xml 773 BLAKE2B 86acea4a75f28be460a539238940e93aaa5f3a71f66926691c5725143f91e45a3575ff31e805bbfe787ec82f8ea2c8554708bd71031aba7ff167a1728f77f4a9 SHA512 bd5b1185a8a92e07c79eca9f196589ac391b261c501ad12f45bc64e0771a31e4ea09d4cd5e144154233893e7636b726653c9995ec0e6a5750d7f4057202b1332
diff --git a/dev-haskell/cipher-aes128/cipher-aes128-0.7.0.5-r1.ebuild b/dev-haskell/cipher-aes128/cipher-aes128-0.7.0.5-r1.ebuild
new file mode 100644
index 000000000000..fea7988f16ec
--- /dev/null
+++ b/dev-haskell/cipher-aes128/cipher-aes128-0.7.0.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.2
+#hackport: flags: -test,-halvm
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="AES and common modes using AES-NI when available"
+HOMEPAGE="https://github.com/TomMD/cipher-aes128"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/cereal:=[profile?]
+ >=dev-haskell/crypto-api-0.13:=[profile?]
+ dev-haskell/tagged:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3 <dev-haskell/cabal-3.3
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'Cabal >= 1.10 && < 3.1' 'Cabal >= 1.10 && < 3.3'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-halvm \
+ --flag=-test
+}
diff --git a/dev-haskell/cipher-aes128/metadata.xml b/dev-haskell/cipher-aes128/metadata.xml
new file mode 100644
index 000000000000..3c77a6d727ea
--- /dev/null
+++ b/dev-haskell/cipher-aes128/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Cipher-aes128 is an implementation of AES and common modes of operation. It borrows Hanquez's C AES code (see 'cipher-aes') but
+ is unique due to including compile-time detection of
+ NI compiler support, a slightly more functional interface
+ for GCM operations, exposure of 'Ptr' based operations via the .Internal module, and build-in crypto-api support.
+ Cipher-aes128 was originally developed as "'cipher-aes' plus trampolines", which has since been adopted into cipher-aes.
+ </longdescription>
+</pkgmetadata>