summaryrefslogtreecommitdiff
path: root/dev-haskell/cipher-blowfish
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/cipher-blowfish
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/cipher-blowfish')
-rw-r--r--dev-haskell/cipher-blowfish/Manifest3
-rw-r--r--dev-haskell/cipher-blowfish/cipher-blowfish-0.0.3.ebuild32
-rw-r--r--dev-haskell/cipher-blowfish/metadata.xml14
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/cipher-blowfish/Manifest b/dev-haskell/cipher-blowfish/Manifest
new file mode 100644
index 000000000000..bdb46d873138
--- /dev/null
+++ b/dev-haskell/cipher-blowfish/Manifest
@@ -0,0 +1,3 @@
+DIST cipher-blowfish-0.0.3.tar.gz 12876 BLAKE2B 56eb4c925055b8ddac187ad36a7f1fb2f28ff337812eef81fadeb5cd519df6fdd8e41b0047d4e15eea5e567c0440ca5c5c9fb65887b3687d85f9a8fae68308fe SHA512 5fcccde71c1324b34e54c01c41d878150ab8db48728d1bfc21406eda58e4a363de8397f395eaa25a6fb26e4d8c95683abafe0c6bf42d7853db07d768ed245cc0
+EBUILD cipher-blowfish-0.0.3.ebuild 913 BLAKE2B f20b490131b08cdc5c8e918382e86a281f28275e39d1013965741f3640ba83abec38355305b5c0b9c1501ea2ec75e87206dd22bbad91ed10802442c18bd1ab4e SHA512 b32109b7663cfc58177245a0cdfc155b6cf978da80f0bb4e0fbaac3e3c346ef2a354aaab94c83025d7eb32c35a0ea39d8e6d294c17254d9bf485818bae38f5c8
+MISC metadata.xml 408 BLAKE2B 9c472f3cb9f87473130090ec2540adb6cab96a52f1a65312e2dc81a52205f295960aa3115cbdcd452697028401727327cc7f912ce67fac1287b4479178ecddcf SHA512 2bd4a2e2002e6eee912a1752cd5f410cf11e0a47dc21de116f832aac90f715afc5e32b4d8a37866a095ec73bab6f1a13d3acb92f9353791dde32eeaf1a08fc67
diff --git a/dev-haskell/cipher-blowfish/cipher-blowfish-0.0.3.ebuild b/dev-haskell/cipher-blowfish/cipher-blowfish-0.0.3.ebuild
new file mode 100644
index 000000000000..f34e3c4e54d0
--- /dev/null
+++ b/dev-haskell/cipher-blowfish/cipher-blowfish-0.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Blowfish cipher"
+HOMEPAGE="https://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.3:=[profile?] <dev-haskell/crypto-cipher-types-0.1:=[profile?]
+ >=dev-haskell/securemem-0.1.2:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/crypto-cipher-tests
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
diff --git a/dev-haskell/cipher-blowfish/metadata.xml b/dev-haskell/cipher-blowfish/metadata.xml
new file mode 100644
index 000000000000..61f93ec8edbc
--- /dev/null
+++ b/dev-haskell/cipher-blowfish/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Blowfish cipher primitives
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-crypto-cipher</remote-id>
+ </upstream>
+</pkgmetadata>