summaryrefslogtreecommitdiff
path: root/dev-haskell/connection/connection-0.3.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/connection/connection-0.3.1-r1.ebuild
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/connection/connection-0.3.1-r1.ebuild')
-rw-r--r--dev-haskell/connection/connection-0.3.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/connection/connection-0.3.1-r1.ebuild b/dev-haskell/connection/connection-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..57d42d31b36a
--- /dev/null
+++ b/dev-haskell/connection/connection-0.3.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_HACKAGE_REVISION=2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple and easy network connections API"
+HOMEPAGE="https://github.com/vincenthz/hs-connection"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="dev-haskell/basement:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/network-2.6.3:=[profile?]
+ >=dev-haskell/socks-0.6:=[profile?]
+ >=dev-haskell/tls-1.4:=[profile?] <dev-haskell/tls-1.7:=[profile?]
+ >=dev-haskell/x509-1.5:=[profile?]
+ >=dev-haskell/x509-store-1.5:=[profile?]
+ >=dev-haskell/x509-system-1.5:=[profile?]
+ >=dev-haskell/x509-validation-1.5:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"