summaryrefslogtreecommitdiff
path: root/dev-haskell/connection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/connection
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/connection')
-rw-r--r--dev-haskell/connection/Manifest5
-rw-r--r--dev-haskell/connection/connection-0.2.4.ebuild35
-rw-r--r--dev-haskell/connection/connection-0.2.5.ebuild33
-rw-r--r--dev-haskell/connection/metadata.xml19
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-haskell/connection/Manifest b/dev-haskell/connection/Manifest
new file mode 100644
index 000000000000..f5c2c7eeb2ae
--- /dev/null
+++ b/dev-haskell/connection/Manifest
@@ -0,0 +1,5 @@
+DIST connection-0.2.4.tar.gz 11067 BLAKE2B a99a7430093f3bf279ffcc709dd3b52050e1534b50683289f68ae00a86cff9269ff5bafdfd1b2a46fd6b55b32f6b4ca2805083cedaf0e7d86c44943dab827deb SHA512 7a55f5bf8b35a8a03553051b38a01e3791e9c51db3222f5c91e77310cc9d61307e9d934d59e31f82be38804f1b9c60cd8856351b03e007e3b7a3c883abaabb48
+DIST connection-0.2.5.tar.gz 7576 BLAKE2B 312e65c9f25b97d7ba0325baae93ebbcd6b8a212d5fd3f48361982dcc3dccc3ccaeb273a8b74b95482bcdb68269b1f3177037ac4951871d25a97fbe501f2e94b SHA512 02f02bfe48aa2f667986433d11fc7723aed8e87deb38082a6eacf009901334db2acb95c254a2cebd0b6c035bcdb6536f51af6c5dfdcc1ee51a13c1b7383460c4
+EBUILD connection-0.2.4.ebuild 982 BLAKE2B 55543d6d98b4ac1875a0faac635dbc7e83a58c4eabaadf2644c883fe4c3db3e990d3566d40bebde5f1e599cb66c3ffee4f375a4dbe9de2aeb7ce94333c3556f7 SHA512 6d5696e08b4b5d6124992226fb2cce74e141e9e06f738a160367183554886bf83793b21a9409f409e71c5eaddfb24fa67afe50b8832a6b6c5ed9959a4ff527eb
+EBUILD connection-0.2.5.ebuild 910 BLAKE2B bd0982141c6cfbb66c76ab5107dd2ab24663fcf6e1d5da0ef95cbff3762fa0f5df93fd49561f2fcd5aeab94d57dc744f54337e5cb1b373c6b68318b559269bb9 SHA512 e13b0dc6e934785cdd5bcabfbad048a01494b5222d73ad196f7f08ef0ba270141ec8479e286411e7985740c35d2d4e03920a9585e6674e957d8048ced514ad71
+MISC metadata.xml 605 BLAKE2B 93b777894909dca02df5c082ae4eb35417336a8dd306ad8889662df406eda6b1972c6dc20cc6d170ad6f0fa6c3634415b3b0e0e4d4786cb6a958e6afa5727564 SHA512 a04bbc4f237d9c2bb70b18c4559ddb04e04a7f1056c38f5f1d34fcaea97999556f176ff5e7a0704f03b9a2e962334823b1571448a6586dd357ac8a296891db29
diff --git a/dev-haskell/connection/connection-0.2.4.ebuild b/dev-haskell/connection/connection-0.2.4.ebuild
new file mode 100644
index 000000000000..653bb9d771dd
--- /dev/null
+++ b/dev-haskell/connection/connection-0.2.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple and easy network connections API"
+HOMEPAGE="https://github.com/vincenthz/hs-connection"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ dev-haskell/crypto-random:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ dev-haskell/securemem:=[profile?]
+ >=dev-haskell/socks-0.4:=[profile?]
+ >=dev-haskell/tls-1.2:=[profile?]
+ >=dev-haskell/x509-1.4:=[profile?]
+ >=dev-haskell/x509-store-1.4:=[profile?]
+ >=dev-haskell/x509-system-1.4:=[profile?]
+ >=dev-haskell/x509-validation-1.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/connection/connection-0.2.5.ebuild b/dev-haskell/connection/connection-0.2.5.ebuild
new file mode 100644
index 000000000000..55df3cc7be2f
--- /dev/null
+++ b/dev-haskell/connection/connection-0.2.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple and easy network connections API"
+HOMEPAGE="https://github.com/vincenthz/hs-connection"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ >=dev-haskell/socks-0.4:=[profile?]
+ >=dev-haskell/tls-1.3:=[profile?]
+ >=dev-haskell/x509-1.5:=[profile?]
+ >=dev-haskell/x509-store-1.5:=[profile?]
+ >=dev-haskell/x509-system-1.5:=[profile?]
+ >=dev-haskell/x509-validation-1.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/connection/metadata.xml b/dev-haskell/connection/metadata.xml
new file mode 100644
index 000000000000..e0146f287c42
--- /dev/null
+++ b/dev-haskell/connection/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Simple network library for all your connection need.
+
+ Features: Really simple to use, SSL/TLS, SOCKS.
+
+ This library provides a very simple api to create sockets
+ to a destination with the choice of SSL/TLS, and SOCKS.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-connection</remote-id>
+ </upstream>
+</pkgmetadata>