summaryrefslogtreecommitdiff
path: root/dev-haskell/criterion/criterion-1.0.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/criterion/criterion-1.0.2.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/criterion/criterion-1.0.2.0.ebuild')
-rw-r--r--dev-haskell/criterion/criterion-1.0.2.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/criterion/criterion-1.0.2.0.ebuild b/dev-haskell/criterion/criterion-1.0.2.0.ebuild
new file mode 100644
index 000000000000..b080fc751f88
--- /dev/null
+++ b/dev-haskell/criterion/criterion-1.0.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Robust, reliable performance measurement and analysis"
+HOMEPAGE="http://www.serpentine.com/criterion"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.8:=[profile?]
+ dev-haskell/ansi-wl-pprint:=[profile?]
+ >=dev-haskell/binary-0.5.1.0:=[profile?]
+ >=dev-haskell/cassava-0.3.0.0:=[profile?]
+ dev-haskell/either:=[profile?]
+ >=dev-haskell/glob-0.7.2:=[profile?]
+ >=dev-haskell/hastache-0.6.0:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?]
+ >=dev-haskell/mwc-random-0.8.0.3:=[profile?]
+ >=dev-haskell/optparse-applicative-0.11:=[profile?]
+ >=dev-haskell/parsec-3.1.0:=[profile?]
+ >=dev-haskell/statistics-0.13.2.1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-haskell/vector-0.7.1:=[profile?]
+ >=dev-haskell/vector-algorithms-0.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/test-framework-0.4
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.2 )
+"