summaryrefslogtreecommitdiff
path: root/dev-haskell/crypto-pubkey
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/crypto-pubkey
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/crypto-pubkey')
-rw-r--r--dev-haskell/crypto-pubkey/Manifest3
-rw-r--r--dev-haskell/crypto-pubkey/crypto-pubkey-0.2.8.ebuild35
-rw-r--r--dev-haskell/crypto-pubkey/metadata.xml18
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-haskell/crypto-pubkey/Manifest b/dev-haskell/crypto-pubkey/Manifest
new file mode 100644
index 000000000000..fee75b796e93
--- /dev/null
+++ b/dev-haskell/crypto-pubkey/Manifest
@@ -0,0 +1,3 @@
+DIST crypto-pubkey-0.2.8.tar.gz 46405 BLAKE2B ee04b805204899ec6fdc1cfcda7a1ac83010805396308f9be7b2e885d52245f7ac77ad9caa7028afc2a3deaa594126a36ab4b93631227cf274e40dacb252b56a SHA512 9e7d54421fdb3c53964688831a2ca5f5379e141e7924af76916d868300833c0dbde22392e1452f80aaf2ec7a9a52de6b429a6f8f78b8fbef6c32f2f31202ed06
+EBUILD crypto-pubkey-0.2.8.ebuild 1006 BLAKE2B 56dcb5875ca09502e71f1978a1d381826e90aad57244b87e3df35c2e9f0317c7c31773afe4b98e267acd747461b5672562f696ffe0a476601b45d32e29868764 SHA512 4bf10b073f27535e8256143cc322e4ea2c1e905b8d4676d815ab227d048d4a7bc7a83eb4eba41b981b89a3142b546359d1438c2843c937d5a70fc38efcc89078
+MISC metadata.xml 550 BLAKE2B e4921e40eb276a11ba0ee29e7cfe8acb8d03ba4cae9f86ad4d13b4281971a0284a0cb1be9d88db5342fd48533cefbc10b88bb689bbd336d8176919b7e1cb8fad SHA512 6bc022c97cb51ca0de160f9152ca0a3eabc143ab3c35cc4de6a06f76ad559a87ab931db7dab4358ab05f750528f1e393ed0ec9b490ed7c1f06821bd1c443e195
diff --git a/dev-haskell/crypto-pubkey/crypto-pubkey-0.2.8.ebuild b/dev-haskell/crypto-pubkey/crypto-pubkey-0.2.8.ebuild
new file mode 100644
index 000000000000..a15a2eb4bf51
--- /dev/null
+++ b/dev-haskell/crypto-pubkey/crypto-pubkey-0.2.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Public Key cryptography"
+HOMEPAGE="https://github.com/vincenthz/hs-crypto-pubkey"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RESTRICT=test # missing files
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/crypto-numbers-0.2.2:=[profile?]
+ >=dev-haskell/crypto-pubkey-types-0.4.1:=[profile?] <dev-haskell/crypto-pubkey-types-0.5:=[profile?]
+ >=dev-haskell/crypto-random-0.0:=[profile?] <dev-haskell/crypto-random-0.1:=[profile?]
+ >=dev-haskell/cryptohash-0.9.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-kat
+ dev-haskell/tasty-quickcheck )
+"
diff --git a/dev-haskell/crypto-pubkey/metadata.xml b/dev-haskell/crypto-pubkey/metadata.xml
new file mode 100644
index 000000000000..07093d50668a
--- /dev/null
+++ b/dev-haskell/crypto-pubkey/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Public Key cryptography
+
+ Supports RSA PKCS15, RSA OAEP, RSA PSS, DSA, ElGamal signature.
+
+ Also have primitive support for Diffie Hellman, and ElGamal encryption
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-crypto-pubkey</remote-id>
+ </upstream>
+</pkgmetadata>