summaryrefslogtreecommitdiff
path: root/dev-haskell/cryptohash-md5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/cryptohash-md5
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/cryptohash-md5')
-rw-r--r--dev-haskell/cryptohash-md5/Manifest3
-rw-r--r--dev-haskell/cryptohash-md5/cryptohash-md5-0.11.100.1.ebuild38
-rw-r--r--dev-haskell/cryptohash-md5/metadata.xml24
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-haskell/cryptohash-md5/Manifest b/dev-haskell/cryptohash-md5/Manifest
new file mode 100644
index 000000000000..bc6d18cba5e5
--- /dev/null
+++ b/dev-haskell/cryptohash-md5/Manifest
@@ -0,0 +1,3 @@
+DIST cryptohash-md5-0.11.100.1.tar.gz 10472 BLAKE2B cc7c99922b05c8df11a7253e6c0dd3ab1399ff739548280fa762b01c507e6d620ab51ccf6c6e791572ae432448118356d1b8879767f4ca245ae59e0daaed2058 SHA512 f2efb197005ed5f12a7c2be490a64a83186cacb34eaedec6cbd76e52c30221733da1d31201c5209538226508db760fd9eed0afc8d72643e1509b32c7287cb12e
+EBUILD cryptohash-md5-0.11.100.1.ebuild 1083 BLAKE2B be2d63ace440e88e85cadbeafd7db617971384d0546d860099aa737abd34c16c70f3a7070f0c5f2197e48be9e510d383af083a14f163b4b4fa2736a6cf58321a SHA512 374b04c403a9ed15b4d976d60edd210141c0bfc1ed9752df2a4b8240d98289cb9b66dd99643d561b6d78e97b3e00066e0e19d300e403021897935714ee530fcb
+MISC metadata.xml 1136 BLAKE2B cd448de1b5bef8a190d7c6be94244e85391a031aeba638e9231c5bbe2792885e08781d036ca514b92bb53c18b7ef8569d727991e1fdc0aa0d570a69af8f0a8af SHA512 04098b3b905f5fc89951a0929309ff7dcd77516b8d1087cebad2f2cbbc8edbdb71f6d83175ba5a0423fd7f57496ab2d131d7d1ed868684a602cd8ae8106befc1
diff --git a/dev-haskell/cryptohash-md5/cryptohash-md5-0.11.100.1.ebuild b/dev-haskell/cryptohash-md5/cryptohash-md5-0.11.100.1.ebuild
new file mode 100644
index 000000000000..0da3dff2e031
--- /dev/null
+++ b/dev-haskell/cryptohash-md5/cryptohash-md5-0.11.100.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast, pure and practical MD5 implementation"
+HOMEPAGE="https://github.com/hvr/cryptohash-md5"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/base16-bytestring-0.1.1 <dev-haskell/base16-bytestring-0.2
+ >=dev-haskell/puremd5-2.1.3 <dev-haskell/puremd5-2.2
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/tasty-quickcheck-0.8 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'base >= 4.5 && < 4.10' 'base >= 4.5' \
+ 'tasty == 0.11.*' 'tasty >= 0.11' \
+ 'tasty-quickcheck == 0.8.*' 'tasty-quickcheck >= 0.8' \
+ 'tasty-hunit == 0.9.*' 'tasty-hunit >= 0.9'
+ default
+}
diff --git a/dev-haskell/cryptohash-md5/metadata.xml b/dev-haskell/cryptohash-md5/metadata.xml
new file mode 100644
index 000000000000..fc0f69d6e24b
--- /dev/null
+++ b/dev-haskell/cryptohash-md5/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A practical incremental and one-pass, pure API to the
+ &lt;https://en.wikipedia.org/wiki/MD5 MD5 hash algorithm&gt;
+ (including &lt;https://en.wikipedia.org/wiki/HMAC HMAC&gt; support)
+ with performance close to the fastest implementations available in other languages.
+
+ The implementation is made in C with a haskell FFI wrapper that hides the C implementation.
+
+ NOTE: This package has been forked off @cryptohash-0.11.7@ because the @cryptohash@ package
+ has been deprecated and so this package continues to satisfy the need for a lightweight package
+ providing the MD5 hash algorithm without any dependencies on packages other than
+ @base@ and @bytestring@.
+
+ Consequently, this package can be used as a drop-in replacement for @cryptohash@&#39;s
+ &quot;Crypto.Hash.MD5&quot; module, though with a clearly smaller footprint.
+ </longdescription>
+</pkgmetadata>